summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-12 16:08:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:30 +0200
commit78086c007cb0cdd03c8212763531644624998a40 (patch)
tree48ea34fe64d275f8c86bc8df033c79cc12776974 /app-vim/alternate
parentwww-apache/mod_jk: add verify-sig (diff)
downloadgentoo-78086c007cb0cdd03c8212763531644624998a40.tar.gz
gentoo-78086c007cb0cdd03c8212763531644624998a40.tar.bz2
gentoo-78086c007cb0cdd03c8212763531644624998a40.zip
app-vim/alternate: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/alternate')
-rw-r--r--app-vim/alternate/alternate-2.18-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/alternate/alternate-2.18-r3.ebuild b/app-vim/alternate/alternate-2.18-r3.ebuild
new file mode 100644
index 000000000000..7588fe2d8ab9
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="
+ https://github.com/vim-scripts/a.vim
+ https://www.vim.org/scripts/script.php?script_id=31"
+SRC_URI="
+ https://github.com/vim-scripts/a.vim/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://www.vim.org/scripts/download_script.php?src_id=6347 -> ${PN}.txt"
+S="${WORKDIR}/a.vim-${PV}"
+
+LICENSE="alternate"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+src_prepare() {
+ default
+ mkdir -p "${S}/doc" || die
+ cp "${DISTDIR}/${PN}.txt" "${S}/doc" || die
+}