summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-15 21:11:17 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-15 21:12:37 -0400
commitf5541d1deb040690b1e876fb5a69eb489be13c30 (patch)
treebb346fcdea5fda766f584b86f175b5f005cd3c48 /app-text
parentapp-text/calibre: drop old for security cleanup (diff)
downloadgentoo-f5541d1deb040690b1e876fb5a69eb489be13c30.tar.gz
gentoo-f5541d1deb040690b1e876fb5a69eb489be13c30.tar.bz2
gentoo-f5541d1deb040690b1e876fb5a69eb489be13c30.zip
app-text/libmspub: backport another missing include for gcc-15 this time
Closes: https://bugs.gentoo.org/937418 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libmspub/files/libmspub-0.1.4-gcc15.patch42
-rw-r--r--app-text/libmspub/libmspub-0.1.4.ebuild7
2 files changed, 48 insertions, 1 deletions
diff --git a/app-text/libmspub/files/libmspub-0.1.4-gcc15.patch b/app-text/libmspub/files/libmspub-0.1.4-gcc15.patch
new file mode 100644
index 000000000000..31377b852de4
--- /dev/null
+++ b/app-text/libmspub/files/libmspub-0.1.4-gcc15.patch
@@ -0,0 +1,42 @@
+From 06cd691e6d9664847d0fb5f096e296be85bedc59 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@gentoo.org>
+Date: Thu, 15 Aug 2024 20:55:25 -0400
+Subject: [PATCH] fix missing include
+
+int64_t comes from stdint.h, but it was never included. This is
+transitively provided by some headers, on some versions of GCC, but in
+GCC 15 a bit of routine cleanup means this header is no longer silently
+exposed to arbitrary codebases without asking.
+
+As such, it fails to build.
+
+In upstream libmspub commit 28c545e7d04d58af998bcf4af5d1bb326d29836c,
+the boost cstdint header was added as part of other work. I am not sure
+why -- maybe to fix this missing header? :D But using all of boost for
+this is a bit odd and unnecessary, especially when not backporting an
+entire commit.
+
+Add in the correct stdlib header as a local backport while distros wait
+for libmspub to release a new version.
+
+Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
+---
+ src/lib/Coordinate.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/lib/Coordinate.h b/src/lib/Coordinate.h
+index bec3fe2..b87608d 100644
+--- a/src/lib/Coordinate.h
++++ b/src/lib/Coordinate.h
+@@ -10,6 +10,8 @@
+ #ifndef INCLUDED_COORDINATE_H
+ #define INCLUDED_COORDINATE_H
+
++#include <cstdint>
++
+ #include "MSPUBConstants.h"
+
+ namespace libmspub
+--
+2.44.2
+
diff --git a/app-text/libmspub/libmspub-0.1.4.ebuild b/app-text/libmspub/libmspub-0.1.4.ebuild
index 78d0df1963cf..40612b0cc463 100644
--- a/app-text/libmspub/libmspub-0.1.4.ebuild
+++ b/app-text/libmspub/libmspub-0.1.4.ebuild
@@ -33,7 +33,12 @@ BDEPEND="
doc? ( app-text/doxygen )
"
-PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
+PATCHES=(
+ # upstream backport
+ "${FILESDIR}/${P}-gcc10.patch"
+ # manually backported
+ "${FILESDIR}/${P}-gcc15.patch"
+)
src_prepare() {
default