summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-19 22:51:11 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-21 12:51:03 -0700
commit2e518e017374461466c1138b4478843b8e878108 (patch)
tree681f342a570a13a79f95916da22dbdbc67d2f46c /app-text
parentapp-text/gspell: Version bump to 1.8.2 (diff)
downloadgentoo-2e518e017374461466c1138b4478843b8e878108.tar.gz
gentoo-2e518e017374461466c1138b4478843b8e878108.tar.bz2
gentoo-2e518e017374461466c1138b4478843b8e878108.zip
app-text/enchant: Version bump to 2.2.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.2.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index be0383a051c0..14f5a7bbd826 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -3,3 +3,4 @@ DIST enchant-2.1.0.tar.gz 962857 BLAKE2B f1ee729f20f06c14cbe81c27eeff5ff3bfe9e81
DIST enchant-2.1.1.tar.gz 961821 BLAKE2B 1aaedc16e2108a382390c9401233d6a77dcff8732fb0af1a35816993b8eb127f22f9e6f4359b997f6793f53dd37c50c1c69d2aa09cf53bb5c47baa47277e044e SHA512 5cb57198ea826da6d9ed9042edca87fcca9b811e8e75b382ed1568c5b1d8d4f8d6ba732a167c8d52261cfce540f23f84bd4d2889a4beafd2db1d8509c0b6bc15
DIST enchant-2.1.2.tar.gz 963236 BLAKE2B 3adaf9d96c7e2d7c5e31fe31ac426230f2e88b1cd6f68157e11f13c30fc5c161723d5a5b40bbe158307ce7352e098cd22272f4a75786854f7d82a0c5694b0f2b SHA512 6cb2eeccc617c005998b16ebc33a84a05cec116b26fd679fc1416110821a85a16605c8564672e1168ac6c865cfcca6680005d1219aa615ca1c2393bd523ae0c4
DIST enchant-2.2.3.tar.gz 957451 BLAKE2B 294c4eb7afbe97a2c8076b1b26640cb15d13dde64de7879557992e3c8ec96d68ff4fbc2c911d3c6d8811d4d5ca5a104040941ab59f8a18e324134e7ac38a2dfa SHA512 abde9d6fec25edff694570455fd4c6e8e2e2c41a6b133bbb31a344761137a354cc1c655e53374cf712bf311c3732dc721e9ffd2dc933d78ec8ccf224350635d6
+DIST enchant-2.2.4.tar.gz 953026 BLAKE2B c1745c365c4084d92988105e072b4776e7f565a53748fdda67ab792777ce78276de5f843ae095d7c025f4f08cfa5daa5e3f9c26acf4e98b0978d589c9e9e076b SHA512 3860f04e276e1afa8969041b3f57411136d6b96ecf90996cdb122739e87be432f12219d2635c29d2e7ef3f2eeb366013026b6f8327a9749ffbc3a1dfafb4b870
diff --git a/app-text/enchant/enchant-2.2.4.ebuild b/app-text/enchant/enchant-2.2.4.ebuild
new file mode 100644
index 000000000000..b9445634e884
--- /dev/null
+++ b/app-text/enchant/enchant-2.2.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="aspell +hunspell static-libs test"
+REQUIRED_USE="|| ( hunspell aspell )"
+
+# FIXME: depends on unittest++ but through pkgconfig which is a Debian hack, bug #629742
+COMMON_DEPENDS="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )"
+
+RDEPEND="${COMMON_DEPENDS}"
+
+DEPEND="${COMMON_DEPENDS}
+ virtual/pkgconfig
+"
+# test? ( dev-libs/unittest++ )
+
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ $(use_with aspell) \
+ $(use_with hunspell) \
+ $(use_enable static-libs static) \
+ --without-hspell \
+ --without-voikko \
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}