summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-19 13:08:55 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-19 13:12:19 +0200
commit1d398aedb77a4c6ebec64a7a0e156261d5be2223 (patch)
tree150e2169235849b2068976cad6b090dac208e09f /app-text/xiphos
parentdev-util/kbuild: Synced live ebuild (diff)
downloadgentoo-1d398aedb77a4c6ebec64a7a0e156261d5be2223.tar.gz
gentoo-1d398aedb77a4c6ebec64a7a0e156261d5be2223.tar.bz2
gentoo-1d398aedb77a4c6ebec64a7a0e156261d5be2223.zip
app-text/xiphos: fix dev-libs/glib-2.68.0 build error
Closes: https://bugs.gentoo.org/784089 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text/xiphos')
-rw-r--r--app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch10
-rw-r--r--app-text/xiphos/xiphos-4.2.1.ebuild3
2 files changed, 12 insertions, 1 deletions
diff --git a/app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch b/app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch
new file mode 100644
index 000000000000..10bca560fb03
--- /dev/null
+++ b/app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch
@@ -0,0 +1,10 @@
+--- a/cmake/config.h.cmake.in
++++ b/cmake/config.h.cmake.in
+@@ -63,5 +63,7 @@
+ // strcasestr
+ #cmakedefine HAVE_STRCASESTR 1
+
++// glib-2.68.0+ compatibility
++#define GLIB_VERSION_MIN_REQUIRED (GLIB_VERSION_2_26)
+
+ #endif
diff --git a/app-text/xiphos/xiphos-4.2.1.ebuild b/app-text/xiphos/xiphos-4.2.1.ebuild
index a79db9af7296..6dab6793c988 100644
--- a/app-text/xiphos/xiphos-4.2.1.ebuild
+++ b/app-text/xiphos/xiphos-4.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,7 @@ BDEPEND="${COMMON}
PATCHES=(
"${FILESDIR}"/${PN}-4.2.1-appdata_metainfo.patch
+ "${FILESDIR}"/${PN}-4.2.1-glib_version_min_required.patch
)
src_configure() {