summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-23 18:42:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-23 20:48:50 +0300
commit8186f43b9ab22278291c2930fbb981c0e0faf84e (patch)
tree9f368b66409b6d58aee108d182ee9eafd33fb155 /app-text/vgrep
parentapp-text/sigil: add 2.2.1 (diff)
downloadgentoo-8186f43b9ab22278291c2930fbb981c0e0faf84e.tar.gz
gentoo-8186f43b9ab22278291c2930fbb981c0e0faf84e.tar.bz2
gentoo-8186f43b9ab22278291c2930fbb981c0e0faf84e.zip
app-text/vgrep: add 2.8.0
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37258 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text/vgrep')
-rw-r--r--app-text/vgrep/Manifest1
-rw-r--r--app-text/vgrep/vgrep-2.8.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/vgrep/Manifest b/app-text/vgrep/Manifest
index dfc67e995979..c87f0bfe8493 100644
--- a/app-text/vgrep/Manifest
+++ b/app-text/vgrep/Manifest
@@ -1,2 +1,3 @@
DIST vgrep-2.6.0.tar.gz 1589155 BLAKE2B 847954ccf020c2b7f54360aab2fd9e3fc897dfd3ceab7d9ecd79f378c18196048649b37f4f9b62dc8f2af46f874a8433c8a20e5e025ca9e0f08b8f6859b0dd40 SHA512 712ca1ab4318a69fbb9f0e60343c188b292c59c52ca488adb1db546937822b0e49a49541e2b9e69cec6b721003198518f530521f4c726988516bcd64e7247846
DIST vgrep-2.7.0.tar.gz 1998937 BLAKE2B 8f5bf53814604ff3bdf7492ec8ad96811a62c9accc0664d07db86039e117686f551c6aaba40e5af4e1b646289a0e996b4f1cade9fc1a197778504e5c8d114830 SHA512 5cc9e866c6de9b024d29dc9aeeb87d6eea23becde63968b2a9266412bbe44920fa13d5e7dda47bb46135301ff7f5fd79e02ec2da8a9a694183d9e63aad64478d
+DIST vgrep-2.8.0.tar.gz 2039369 BLAKE2B a01191c860fb615ff569e3b3e9b49dfeab9d534bd8a94d07ff8ce49f65bedd75eda8ae79127e0e3eb7cf2343e6493815a954f74318296c89397a384566448f69 SHA512 1fbd674a7fddffede70a9d0715bf09359d48abf5c238cace43996a222e3e34ec73a7911f62b8476a2dcef40485ce192476067fd99d52b7fa0e7e3fe9297f461e
diff --git a/app-text/vgrep/vgrep-2.8.0.ebuild b/app-text/vgrep/vgrep-2.8.0.ebuild
new file mode 100644
index 000000000000..097f33c9270a
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests just run golangci-lint
+RESTRICT="test"
+
+BDEPEND="dev-go/go-md2man"
+
+src_prepare() {
+ default
+ sed -e '/-ldflags/s/-s //' -i Makefile || die # bug 795345
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}