summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/po4a
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/files/0.41-po4a-build.patch16
-rw-r--r--app-text/po4a/files/compare-po.pl37
-rw-r--r--app-text/po4a/metadata.xml10
-rw-r--r--app-text/po4a/po4a-0.45-r1.ebuild35
-rw-r--r--app-text/po4a/po4a-0.45-r2.ebuild64
6 files changed, 163 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
new file mode 100644
index 000000000000..2a58986d8c5d
--- /dev/null
+++ b/app-text/po4a/Manifest
@@ -0,0 +1 @@
+DIST po4a_0.45.orig.tar.gz 2208959 SHA256 f5f47db85b48893d87d921152c96082233975bd0e0a9ee14f58c07d7dff81678 SHA512 e67334b7a45d3c23b7226077e01e12b3c4f1202531596f02851b6a9e7249b2b8a0c37f37ebbaf591753f041a4c6ce42c062b4822e91ac75884dcd0994c27323f WHIRLPOOL 404bb45412fff4cec13304490e5f74ee4a4573d3c755491816cfe501c3e83dbdb58ae3c799516fe21c692c9de6fbc2dd5a261c8039eca2e2777365b27ac358cd
diff --git a/app-text/po4a/files/0.41-po4a-build.patch b/app-text/po4a/files/0.41-po4a-build.patch
new file mode 100644
index 000000000000..f869775ccee2
--- /dev/null
+++ b/app-text/po4a/files/0.41-po4a-build.patch
@@ -0,0 +1,16 @@
+--- a/Po4aBuilder.pm
++++ b/Po4aBuilder.pm
+@@ -29,7 +29,12 @@
+ my $self = shift;
+ $self->depends_on('binpo');
+ $self->make_files_writable("po/pod");
+- system("./share/po4a-build -f po4a-build.conf") && die;
++ { # Fix for massive slowdown/Memory consumption
++ open( my $fh, '-|', qw( ./share/po4a-build -f po4a-build.conf )) or die;
++ while( defined ( my $line = <$fh> ) ){
++ print $line;
++ }
++ }
+ File::Path::mkpath( File::Spec->catdir( 'blib', 'manl10n' ), 0, oct(777) );
+ system ("cp -R _build/po4a/man/* blib/manl10n") && die;
+ }
diff --git a/app-text/po4a/files/compare-po.pl b/app-text/po4a/files/compare-po.pl
new file mode 100644
index 000000000000..c01b9b8f31ee
--- /dev/null
+++ b/app-text/po4a/files/compare-po.pl
@@ -0,0 +1,37 @@
+#! /usr/bin/perl
+# Remove header entry of two PO files and compare them
+
+my $f1 = shift(@ARGV);
+my $f2 = shift(@ARGV);
+
+open IN1, "<", $f1 or die "Unable to read 1st file: $!\n";
+open IN2, "<", $f2 or die "Unable to read 2nd file: $!\n";
+my $inMsgstr = 0;
+my $lineno = 0;
+while (<IN1>) {
+ $lineno ++;
+ if (m/^msgstr/) {
+ $inMsgstr = 1;
+ } elsif ($inMsgstr == 1 && $_ !~ /^"/) {
+ last;
+ }
+}
+$inMsgstr = 0;
+while (<IN2>) {
+ if (m/^msgstr/) {
+ $inMsgstr = 1;
+ } elsif ($inMsgstr == 1 && $_ !~ /^"/) {
+ last;
+ }
+}
+
+# Now compare lines
+while (<IN1>) {
+ $lineno ++;
+ my $l2 = <IN2> or die "Unexpected EOF found when reading $f2\n";
+ $_ eq $l2 or die "Files $f1 and $f2 differ at line $lineno:\n-$_+$l2\n";
+}
+close IN1;
+die "EOF expected at 2nd file\n" unless eof(IN2);
+close IN2;
+exit 0;
diff --git a/app-text/po4a/metadata.xml b/app-text/po4a/metadata.xml
new file mode 100644
index 000000000000..c75fe577173e
--- /dev/null
+++ b/app-text/po4a/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ <description>Proxu maintainer. Assign bugs on him</description>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/po4a/po4a-0.45-r1.ebuild b/app-text/po4a/po4a-0.45-r1.ebuild
new file mode 100644
index 000000000000..ee2d7e292581
--- /dev/null
+++ b/app-text/po4a/po4a-0.45-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Needed because this package also installs to vendor_perl
+GENTOO_DEPEND_ON_PERL_SUBSLOT="yes"
+inherit perl-app
+
+DESCRIPTION="Tools for helping translation of documentation"
+HOMEPAGE="http://po4a.alioth.debian.org"
+SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/SGMLSpm
+ >=sys-devel/gettext-0.13
+ app-text/openjade
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ test? ( app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ virtual/tex-base )"
+
+SRC_TEST="do"
diff --git a/app-text/po4a/po4a-0.45-r2.ebuild b/app-text/po4a/po4a-0.45-r2.ebuild
new file mode 100644
index 000000000000..b4c3282b3d0e
--- /dev/null
+++ b/app-text/po4a/po4a-0.45-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="af ca cs da de eo es et eu fr hr id it ja kn ko nb nl pl pt_BR pt ru sl sv uk vi zh_CN zh_HK"
+PLOCALES_BACKUP="en"
+
+# Needed because this package also installs to vendor_perl
+GENTOO_DEPEND_ON_PERL_SUBSLOT="yes"
+inherit perl-app perl-module l10n
+
+DESCRIPTION="Tools for helping translation of documentation"
+HOMEPAGE="http://po4a.alioth.debian.org"
+SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/SGMLSpm
+ >=sys-devel/gettext-0.13
+ app-text/openjade
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ test? ( app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ virtual/tex-base )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ # Check against locale files in ${S}/pod/bin for mismatches
+ # with languages listed in PLOCALES
+ local locales_path="$S/po/bin"
+ l10n_find_plocales_changes "$locales_path" "" ".po"
+
+ # Array containing locale files to remove
+ local locales_to_remove=( )
+
+ # Get rid of disabled locales
+ my_get_disabled_locales() {
+ local locale=$1
+ local locale_abs_path="$locales_path/$locale.po"
+ locales_to_remove+=$locale_abs_path
+ }
+
+ l10n_for_each_disabled_locale_do my_get_disabled_locales
+
+ einfo "Your LINGUAS lists the following languages: $LINGUAS"
+ einfo "Removing locale files not listed in it ..."
+
+ # perl_rm_files also updates the Manifest file
+ # and therefore silences Perl as to .po files we're about to clean
+ perl_rm_files "${locales_to_remove[@]}"
+}