summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/docbook-xsl-ns-stylesheets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/docbook-xsl-ns-stylesheets')
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/Manifest1
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.78.0.ebuild81
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/metadata.xml16
3 files changed, 98 insertions, 0 deletions
diff --git a/app-text/docbook-xsl-ns-stylesheets/Manifest b/app-text/docbook-xsl-ns-stylesheets/Manifest
new file mode 100644
index 000000000000..90029622bb77
--- /dev/null
+++ b/app-text/docbook-xsl-ns-stylesheets/Manifest
@@ -0,0 +1 @@
+DIST docbook-xsl-ns-1.78.0.tar.bz2 4992293 SHA256 255f67ff33c879e461d7a7550be80477d1bd0b0c3406fa50e9b4037eeb8c598e SHA512 f3b9b52a4ba5670c17086cdf64674080ef82a9226f085887c23c53d2d102611d690895c71d14186cd84a25c7735b05d6c55207f4b2b9084d65889aaac7993cf3 WHIRLPOOL d0f875baddea8317eaf6b5a4d1d0e9b3e4a380fada6414a310a88c3a9ea8fc2f502c249a1862e100138030409f1fa0052514b905ba56fa084c3798d78d0a0396
diff --git a/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.78.0.ebuild b/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.78.0.ebuild
new file mode 100644
index 000000000000..153e80a88bb6
--- /dev/null
+++ b/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.78.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DOCBOOKDIR="/usr/share/sgml/${PN/-//}"
+MY_PN="${PN%-stylesheets}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="http://wiki.docbook.org/topic/DocBookXslStylesheets"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ruby"
+
+RDEPEND=">=app-text/build-docbook-catalog-1.4
+ ruby? ( dev-lang/ruby )"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# Makefile is broken since 1.76.0
+RESTRICT=test
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+
+ insinto ${DOCBOOKDIR}
+ doins VERSION VERSION.xsl
+
+ local i
+ for i in $(find . -maxdepth 1 -mindepth 1 -type d -exec basename {} \;); do
+ [[ "$i" == "epub" ]] && ! use ruby && continue
+
+ cd "${S}"/${i}
+ for doc in ChangeLog README; do
+ if [ -e "$doc" ]; then
+ mv ${doc} ${doc}.${i}
+ dodoc ${doc}.${i}
+ rm ${doc}.${i}
+ fi
+ done
+
+ doins -r "${S}"/${i}
+ done
+
+ if use ruby; then
+ local cmd="dbtoepub${MY_PN#docbook-xsl}"
+
+ # we can't use a symlink or it'll look for the library in the
+ # wrong path.
+ dodir /usr/bin
+ cat - > "${D}"/usr/bin/${cmd} <<EOF
+#!/usr/bin/env ruby
+
+load "${DOCBOOKDIR}/epub/bin/dbtoepub"
+EOF
+ fperms 0755 /usr/bin/${cmd}
+ fi
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+}
diff --git a/app-text/docbook-xsl-ns-stylesheets/metadata.xml b/app-text/docbook-xsl-ns-stylesheets/metadata.xml
new file mode 100644
index 000000000000..d72a3311e701
--- /dev/null
+++ b/app-text/docbook-xsl-ns-stylesheets/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="ruby">
+ Install the Ruby-based dbtoepub script; requires an interpreter
+ compatible with <pkg>app-eselect/eselect-ruby</pkg>.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">docbook</remote-id>
+ </upstream>
+</pkgmetadata>