summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-12 20:13:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-13 00:21:57 +0100
commitdc6cac2e3d82a085d964e3c44f2d7de557a4108d (patch)
treea1d84f18747566f80eb95d22516326cbc6a1c38c /app-shells
parentdev-util/github-cli: add 2.42.0 (diff)
downloadgentoo-dc6cac2e3d82a085d964e3c44f2d7de557a4108d.tar.gz
gentoo-dc6cac2e3d82a085d964e3c44f2d7de557a4108d.tar.bz2
gentoo-dc6cac2e3d82a085d964e3c44f2d7de557a4108d.zip
app-shells/pwsh-bin: bump to 7.4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.4.1.ebuild69
2 files changed, 72 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index e622f35bd6b5..9df73fa0af1e 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -4,3 +4,6 @@ DIST powershell-7.3.9-linux-x64.tar.gz 69086550 BLAKE2B 4e31c219db750fca3d038791
DIST powershell-7.4.0-linux-arm32.tar.gz 69167301 BLAKE2B cedafe01997650f22571546dec6de5877504fd828b89fcc224735e6c4536ab49aaebe2d997349aadaa61638c8cb37b4c0c6d261ec96f3ad228653a9a036b768a SHA512 f6635a0d7a4185df2cc5c361131d4032d852b02b4d620b974344fc72a1a6199dd867d319c269b094bb6c30e55601de7c64c6dadc2562318777e3059b8623267b
DIST powershell-7.4.0-linux-arm64.tar.gz 68068263 BLAKE2B a6e8aab575fc297ce30cf66155adf61994efc290c59fdd1752ec0fef83472d1c356768a928532b0be5c44628b95e1132efef72a1855fccc81ab6d86cab3e218f SHA512 3e0342d3fe1970b46250e0574b81249e6a8f8d18fffacd674282f066a1989758f2b0522d00d0b0e76270d095d67b9a370b421fb96386ff504cbce28bde30abf3
DIST powershell-7.4.0-linux-x64.tar.gz 70925342 BLAKE2B e290ff11e93ac8df8a52af143f1fe629b730f5cf65cc47956c12c2944487bc5de8a813a604f874b90307389b6c1e12302742ce82bf81bb94545aa99f760a9aea SHA512 47b9e6304985080b36e5d2d2b4a9f1705ef000918e6dd4d5d6804d7467db88d9c39bb2033f87e8b9b8d2f35bcf2deeff87980a6e55ebe9b7d745a08bd5c4d34a
+DIST powershell-7.4.1-linux-arm32.tar.gz 69199014 BLAKE2B f17f0ec3f87b39afd90a88dd7a21c3b8bcfec60aef6a6546f3019db76140a3f80732396ba148a72be6f49ea87d43fb5f4aa9c2f699d68783065c159a61b36653 SHA512 57a1e79ca1eed6793991d0de995dd5c439a95ddc59f8aafee24ed4cc72e6f4ef219e9ed3cde0e21e104c17012f385c2a2d039510258b327ecb4e1a0182852866
+DIST powershell-7.4.1-linux-arm64.tar.gz 68192983 BLAKE2B f020f7b68591ce3347967239755c4afae7f681af0fa17c34a1d36d1c524f0c52ddbc53d46d21f8e0a4c18cba734b2596d2b60379cfa7926ef6260b59d4c40d37 SHA512 c42e9a4280da0a342c9d8bbe3a9def35a88cc5e464f6dace96862b8fde416463b9746a676032c096acc952d96ccf9dd15bb4c1604a1085cffeb4e4992b5c947a
+DIST powershell-7.4.1-linux-x64.tar.gz 70945165 BLAKE2B b9f66205bf7ded6682c3fe8639058b6b2a6cbc6cf12b9432970787e88edf3e58564b1a7713decad6c042d60d7a16ffe41726dbd6fda3ae0268f77eab46a42f44 SHA512 3193c28935e474421aabe1f2b1df185fc6f49ed8dc148b60fca9314af48950f0d80aa7872f14830a2c5297ca9c160cf9cfc6b364c94ba72d51da37b9ca590da4
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.4.1.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.4.1.ebuild
new file mode 100644
index 000000000000..1eaa0f3a6e95
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.4.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="app-eselect/eselect-pwsh"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}