summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-09 02:39:38 +0000
committerSam James <sam@gentoo.org>2024-01-09 02:39:38 +0000
commit10cd51b1cac70e3f180a04b2e9ea3c6eb46150fd (patch)
treeef221d2e9ac8d9bc0f2063b21e8a00182de5ccc4 /app-shells
parentdev-libs/libisoburn: fix indentation (diff)
downloadgentoo-10cd51b1cac70e3f180a04b2e9ea3c6eb46150fd.tar.gz
gentoo-10cd51b1cac70e3f180a04b2e9ea3c6eb46150fd.tar.bz2
gentoo-10cd51b1cac70e3f180a04b2e9ea3c6eb46150fd.zip
app-shells/ksh: clean up flag handling
* Filter LTO instead of just -Wno-erroring things indicating it's unsafe * Try to respect CC/AR/NM more Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ksh-1.0.8.ebuild9
-rw-r--r--app-shells/ksh/ksh-9999.ebuild11
2 files changed, 9 insertions, 11 deletions
diff --git a/app-shells/ksh/ksh-1.0.8.ebuild b/app-shells/ksh/ksh-1.0.8.ebuild
index 4cda30c54705..c97a769209a6 100644
--- a/app-shells/ksh/ksh-1.0.8.ebuild
+++ b/app-shells/ksh/ksh-1.0.8.ebuild
@@ -40,18 +40,17 @@ src_compile() {
"-Wno-unused-but-set-variable"
"-Wno-cpp"
"-Wno-maybe-uninitialized"
- "-Wno-lto-type-mismatch"
- "-Wno-error=int-conversion"
- "-Wno-int-conversion"
"-P"
)
append-cflags $(test-flags-CC ${extraflags[@]})
+ append-cflags -fno-strict-aliasing
filter-flags '-fdiagnostics-color=always' # https://github.com/ksh93/ksh/issues/379
- export CCFLAGS="${CFLAGS} -fno-strict-aliasing"
+ filter-lto
+ export CCFLAGS="${CFLAGS}"
tc-export AR CC LD NM
- sh bin/package make SHELL="${BROOT}"/bin/sh || die
+ sh bin/package make AR="${AR}" CC="${CC}" NM="${NM}" SHELL="${BROOT}"/bin/sh || die
}
src_test() {
diff --git a/app-shells/ksh/ksh-9999.ebuild b/app-shells/ksh/ksh-9999.ebuild
index f59df92a2e4a..c97a769209a6 100644
--- a/app-shells/ksh/ksh-9999.ebuild
+++ b/app-shells/ksh/ksh-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,18 +40,17 @@ src_compile() {
"-Wno-unused-but-set-variable"
"-Wno-cpp"
"-Wno-maybe-uninitialized"
- "-Wno-lto-type-mismatch"
- "-Wno-error=int-conversion"
- "-Wno-int-conversion"
"-P"
)
append-cflags $(test-flags-CC ${extraflags[@]})
+ append-cflags -fno-strict-aliasing
filter-flags '-fdiagnostics-color=always' # https://github.com/ksh93/ksh/issues/379
- export CCFLAGS="${CFLAGS} -fno-strict-aliasing"
+ filter-lto
+ export CCFLAGS="${CFLAGS}"
tc-export AR CC LD NM
- sh bin/package make SHELL="${BROOT}"/bin/sh || die
+ sh bin/package make AR="${AR}" CC="${CC}" NM="${NM}" SHELL="${BROOT}"/bin/sh || die
}
src_test() {