summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-06 20:39:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-06 20:40:16 +0300
commiteff4986d8bd2ee868edf18192102cc86262c1fdd (patch)
treefc252b211fccc3cd53d24d3340b380ccd2f75688 /app-shells/bash-completion
parentmedia-libs/libglvnd: Add py3.13 to -9999 too (diff)
downloadgentoo-eff4986d8bd2ee868edf18192102cc86262c1fdd.tar.gz
gentoo-eff4986d8bd2ee868edf18192102cc86262c1fdd.tar.bz2
gentoo-eff4986d8bd2ee868edf18192102cc86262c1fdd.zip
app-shells/bash-completion: fix live ebuild
Bug: https://bugs.gentoo.org/935658 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild21
1 files changed, 2 insertions, 19 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 0cb1ec461db8..ab48b5fd6c59 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit autotools git-r3 python-any-r1
@@ -56,26 +56,9 @@ strip_completions() {
# Now-dead symlinks to deprecated completions
hd ncal
-
- # FreeBSD
- freebsd-update kldload kldunload portinstall portsnap
- pkg_deinstall pkg_delete pkg_info
-
- # For GNU mailman, which isn't packaged. If mailman isn't installed,
- # it triggers a QA warning.
)
- if [[ ${CHOST} = *solaris* ]]; then
- # Triggers QA warning since it only defines a completion on Solaris,
- # to avoid defining a bad one on macOS.
- strip_completions+=(pkgutil)
- fi
-
- local file
- for file in "${strip_completions[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} ||
- die "stripping ${file} failed"
- done
+ rm -v "${strip_completions[@]/#/${ED}/usr/share/bash-completion/completions/}" || die
# remove deprecated completions (moved to other packages)
rm "${ED}"/usr/share/bash-completion/completions/_* || die