summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-09 17:32:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-09 17:46:36 +0100
commitac19b932d5954f5ce774cd809ef19b82b7182ba5 (patch)
tree49aeaa4ef5a76194f628fbf116a1b0d756d83d60 /app-portage
parentdev-python/pip: Patch for newer dev-python/rich support (diff)
downloadgentoo-ac19b932d5954f5ce774cd809ef19b82b7182ba5.tar.gz
gentoo-ac19b932d5954f5ce774cd809ef19b82b7182ba5.tar.bz2
gentoo-ac19b932d5954f5ce774cd809ef19b82b7182ba5.zip
app-portage/time64-prep: Add package, v1
This is the helper package for transitioning 32-bit systems to 64-bit time_t. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/time64-prep/Manifest1
-rw-r--r--app-portage/time64-prep/metadata.xml11
-rw-r--r--app-portage/time64-prep/time64-prep-1.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/app-portage/time64-prep/Manifest b/app-portage/time64-prep/Manifest
new file mode 100644
index 000000000000..7548505bd552
--- /dev/null
+++ b/app-portage/time64-prep/Manifest
@@ -0,0 +1 @@
+DIST time64-prep-1.gh.tar.gz 11439 BLAKE2B 0848d97bb5b6f0df7b7346f5e55670d5b13b6b09fd9427dcbcb67802e5206e440c75f170fd2025b81659fcb4adc0ddb60712fdb726f8e006c0e78012fb51f010 SHA512 ff6c12cf1487695a395c364ba4efde81d9b821cbcf954a705bc38e3908fcc835da77409276fdbfd590562d9778b1f85e7b519904d204d73d44632e6a497e0865
diff --git a/app-portage/time64-prep/metadata.xml b/app-portage/time64-prep/metadata.xml
new file mode 100644
index 000000000000..e61bfb232b74
--- /dev/null
+++ b/app-portage/time64-prep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">projg2/time64-prep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/time64-prep/time64-prep-1.ebuild b/app-portage/time64-prep/time64-prep-1.ebuild
new file mode 100644
index 000000000000..007fb9be8685
--- /dev/null
+++ b/app-portage/time64-prep/time64-prep-1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1
+
+DESCRIPTION="A tool to prepare for (comparatively) safe time64 transition"
+HOMEPAGE="https://github.com/projg2/time64-prep/"
+SRC_URI="
+ https://github.com/projg2/time64-prep/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/patchelf
+ $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+src_install() {
+ python_doscript time64-prep
+ einstalldocs
+}