summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-02-06 13:55:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-02-06 13:55:52 +0200
commit9b87e4c4fb0cc67225eec19cd5cf4bd83d6b952d (patch)
treeadd5f23f4eed9c01f307173d22a938e56ed5faa0 /app-portage
parentdev-python/pycountry: Fix variable order (diff)
downloadgentoo-9b87e4c4fb0cc67225eec19cd5cf4bd83d6b952d.tar.gz
gentoo-9b87e4c4fb0cc67225eec19cd5cf4bd83d6b952d.tar.bz2
gentoo-9b87e4c4fb0cc67225eec19cd5cf4bd83d6b952d.zip
app-portage/pkg-testing-tools: add 0.2.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pkg-testing-tools/Manifest1
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-portage/pkg-testing-tools/Manifest b/app-portage/pkg-testing-tools/Manifest
index 50a14d460562..afc357e73504 100644
--- a/app-portage/pkg-testing-tools/Manifest
+++ b/app-portage/pkg-testing-tools/Manifest
@@ -1,3 +1,4 @@
DIST pkg-testing-tools-0.1.0.tar.gz 6131 BLAKE2B 6d8dddb81e57159df9f2e1897718433d29f330286afb868a1111db4e0bb7a53823df57a5d7084a24fd5807787f169fff137f5c6c0bdcddeec2c59090d9b90775 SHA512 05165d3790b4d38c939226d1149c0c44cd62fe222a199bce8f1e108d12475710f8482f82e2e2e45223ba24fd1b50451dea8b3761c8f474a59e660b9a67bf8ab4
DIST pkg-testing-tools-0.1.2.gh.tar.gz 6180 BLAKE2B 7674573d165e8e04ef4555301bb15e6f3e7b6834096e4b9dcadf74bfc40dabcff5b694a323d6e1c62fa20d965be4f9f8c0b9459c5dacbd01f914669594aa15b4 SHA512 8d5933be8cd596089d4f8f5609d597330a1619b12f08049985b48519ecf10c3fd40971ee76b3bee793c082b8b96832aa2f5a2f6db8e1ca127a374986540e5ffc
DIST pkg-testing-tools-0.2.0.gh.tar.gz 6325 BLAKE2B 0d45311beb6fdbf1847b1227a0ca1402461c38f5036d7953c40752eb0f086b5388051f420c2bad2fa75faeb345885dd65fcc25f594d54e6b14269ff67738f724 SHA512 11815efa0d546f78717ec65f97c57684c4c34f785bd3c7dd254064d3925341ed09e1f3df5912308926643eaf19779cd3a01c32d65a47e19022ffe6043d3a396b
+DIST pkg-testing-tools-0.2.1.gh.tar.gz 10488 BLAKE2B aa3971115924e4e404b4d25ea5b9cdb5393b988561f83c25ec28daad7750cd36e88d106ef06097c785d5a2fa0ae099d63cd83533fdce91d055521a37ac35d9e6 SHA512 258764c61f6df46248f5dabef222122a8746744206b41febadcc5cf115822f4c9c1202e46336c0b617172cc2e0f1b0e1213afc0a95ce431d0dcf04fd4ab61316
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
new file mode 100644
index 000000000000..41d4e5d3029a
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
+SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"