summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-26 10:09:46 +0000
committerSam James <sam@gentoo.org>2024-12-26 10:09:46 +0000
commitf8170672b2949a23581c166284e09370bb195773 (patch)
tree2f0bbceb0ca9f7c312064b9881b44d1da00fcc06 /app-office
parentapp-office/gnucash: don't use installed copy of gnucash for build or tests (diff)
downloadgentoo-f8170672b2949a23581c166284e09370bb195773.tar.gz
gentoo-f8170672b2949a23581c166284e09370bb195773.tar.bz2
gentoo-f8170672b2949a23581c166284e09370bb195773.zip
app-office/gnucash: backport boost-1.87 fix
This allows easier testing of the bug #941426 fix. Closes: https://bugs.gentoo.org/946388 Bug: https://bugs.gentoo.org/941426 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/files/gnucash-5.8-boost-1.87.patch12
-rw-r--r--app-office/gnucash/gnucash-5.8-r100.ebuild2
2 files changed, 14 insertions, 0 deletions
diff --git a/app-office/gnucash/files/gnucash-5.8-boost-1.87.patch b/app-office/gnucash/files/gnucash-5.8-boost-1.87.patch
new file mode 100644
index 000000000000..55263705a4b7
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-5.8-boost-1.87.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/946388
+--- a/libgnucash/app-utils/gnc-quotes.cpp 2024-12-13 17:18:10.294664737 -0800
++++ b/libgnucash/app-utils/gnc-quotes.cpp 2024-12-13 17:18:31.410866021 -0800
+@@ -212,7 +212,7 @@ GncFQQuoteSource::run_cmd (const StrVec&
+ try
+ {
+ std::future<std::vector<char> > out_buf, err_buf;
+- boost::asio::io_service svc;
++ boost::asio::io_context svc;
+
+ auto input_buf = bp::buffer (json_string);
+ bp::child process;
diff --git a/app-office/gnucash/gnucash-5.8-r100.ebuild b/app-office/gnucash/gnucash-5.8-r100.ebuild
index 028e4e012a61..dec0d06fe71f 100644
--- a/app-office/gnucash/gnucash-5.8-r100.ebuild
+++ b/app-office/gnucash/gnucash-5.8-r100.ebuild
@@ -123,6 +123,8 @@ PATCHES=(
# GCC 15 backport
"${FILESDIR}/${PN}-5.8-gcc15.patch"
+
+ "${FILESDIR}/${PN}-5.8-boost-1.87.patch"
)
pkg_setup() {