summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-06 12:01:53 +0000
committerSam James <sam@gentoo.org>2022-12-06 12:02:11 +0000
commite8193b177eb10c32899f3819af0f5c6d48122453 (patch)
treec109172dc224d12aba37340e4ec139f5724a3ae4 /app-office
parentapp-office/gnucash: make tests working (diff)
downloadgentoo-e8193b177eb10c32899f3819af0f5c6d48122453.tar.gz
gentoo-e8193b177eb10c32899f3819af0f5c6d48122453.tar.bz2
gentoo-e8193b177eb10c32899f3819af0f5c6d48122453.zip
app-office/gnucash: style fixes
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch8
-rw-r--r--app-office/gnucash/files/gnucash-4.12-fix-test.patch8
-rw-r--r--app-office/gnucash/gnucash-4.12.ebuild26
3 files changed, 13 insertions, 29 deletions
diff --git a/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch b/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch
index c2b396bcf04f..970d423c7b31 100644
--- a/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch
+++ b/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch
@@ -1,15 +1,11 @@
+https://github.com/Gnucash/gnucash/pull/1472
+
From a52795b022e040d7a93bb4dc352780d832c55390 Mon Sep 17 00:00:00 2001
From: Marco Scardovi <mscardovi@icloud.com>
Date: Sat, 26 Nov 2022 22:38:02 +0100
Subject: [PATCH] Fix test
Signed-off-by: Marco Scardovi <mscardovi@icloud.com>
----
- libgnucash/core-utils/test/CMakeLists.txt | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/libgnucash/core-utils/test/CMakeLists.txt b/libgnucash/core-utils/test/CMakeLists.txt
-index 3b724c7c632..07add8b8699 100644
--- a/libgnucash/core-utils/test/CMakeLists.txt
+++ b/libgnucash/core-utils/test/CMakeLists.txt
@@ -19,9 +19,6 @@ endmacro()
diff --git a/app-office/gnucash/files/gnucash-4.12-fix-test.patch b/app-office/gnucash/files/gnucash-4.12-fix-test.patch
index e80c712214e6..03b4bba29c24 100644
--- a/app-office/gnucash/files/gnucash-4.12-fix-test.patch
+++ b/app-office/gnucash/files/gnucash-4.12-fix-test.patch
@@ -1,15 +1,11 @@
+https://github.com/Gnucash/gnucash/pull/1472
+
From 6fe2028bca49f455b7841d178a712baec8f72919 Mon Sep 17 00:00:00 2001
From: Marco Scardovi <mscardovi@icloud.com>
Date: Thu, 24 Nov 2022 23:20:07 +0100
Subject: [PATCH] Fix test
Signed-off-by: Marco Scardovi <mscardovi@icloud.com>
----
- libgnucash/engine/mocks/fake-qofquery.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libgnucash/engine/mocks/fake-qofquery.cpp b/libgnucash/engine/mocks/fake-qofquery.cpp
-index 15341189aa8..a82dadebf02 100644
--- a/libgnucash/engine/mocks/fake-qofquery.cpp
+++ b/libgnucash/engine/mocks/fake-qofquery.cpp
@@ -59,8 +59,8 @@ static class QofFakeQueryPool
diff --git a/app-office/gnucash/gnucash-4.12.ebuild b/app-office/gnucash/gnucash-4.12.ebuild
index d19d9983eb5e..702eadfdd4b6 100644
--- a/app-office/gnucash/gnucash-4.12.ebuild
+++ b/app-office/gnucash/gnucash-4.12.ebuild
@@ -75,7 +75,6 @@ RDEPEND="
dev-db/libdbi-drivers[sqlite]
)
"
-
DEPEND="
${RDEPEND}
>=sys-devel/gettext-0.20
@@ -84,36 +83,29 @@ DEPEND="
sys-devel/libtool
test? ( >=dev-cpp/gtest-1.8.0 )
"
-
BDEPEND="
dev-lang/swig
dev-util/cmake
virtual/pkgconfig
- || (
- >=sys-devel/gcc-8:*
- >=sys-devel/clang-6:*
- )
"
-
-# For 4.10, they released gnucash-docs-4.10.1 to fix an issue.
PDEPEND="
doc? (
- ~app-doc/gnucash-docs-"${PV}"
+ ~app-doc/gnucash-docs-${PV}
gnome-extra/yelp
)
"
PATCHES=(
- "${FILESDIR}/${PN}"-3.8-examples-subdir.patch
- "${FILESDIR}/${PN}"-3.8-exclude-license.patch
- "${FILESDIR}/${P}"-drop-broken-test.patch
+ "${FILESDIR}"/${PN}-3.8-examples-subdir.patch
+ "${FILESDIR}"/${PN}-3.8-exclude-license.patch
+ "${FILESDIR}"/${P}-drop-broken-test.patch
# will be fixed on future version, see
# https://github.com/Gnucash/gnucash/pull/1472
- "${FILESDIR}/${P}"-fix-test.patch
+ "${FILESDIR}"/${P}-fix-test.patch
)
# guile generates ELF files without use of C or machine code
-# It's a portage's false positive. bug #677600
+# It's a portage false positive, bug #677600
QA_PREBUILT='*[.]go'
pkg_setup() {
@@ -161,7 +153,7 @@ src_configure() {
-DWITH_AQBANKING=$(usex aqbanking)
-DWITH_OFX=$(usex ofx)
-DWITH_PYTHON=$(usex python)
- -DWITH_SQL="${sql_on_off}"
+ -DWITH_SQL=${sql_on_off}
-DWITH_GNUCASH=$(usex gui)
)
@@ -198,9 +190,9 @@ src_install() {
cmake_src_install
if use examples ; then
- docompress -x /usr/share/doc/"${PF}"/examples
+ docompress -x /usr/share/doc/${PF}/examples
else
- rm -r "${ED}"/usr/share/doc/"${PF}"/examples
+ rm -r "${ED}"/usr/share/doc/${PF}/examples
fi
if use python ; then