summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-11-17 12:57:01 +0100
committerPacho Ramos <pacho@gentoo.org>2024-11-17 13:02:34 +0100
commit821ce41261793313d121d7929d466deca148c9cf (patch)
tree73a123a9c09f7e23a9b84778cbe54e55521132b9 /app-office
parentdev-libs/appstream-glib: add 0.8.3 (diff)
downloadgentoo-821ce41261793313d121d7929d466deca148c9cf.tar.gz
gentoo-821ce41261793313d121d7929d466deca148c9cf.tar.bz2
gentoo-821ce41261793313d121d7929d466deca148c9cf.zip
app-office/onlyoffice-bin: add 8.2.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/onlyoffice-bin/Manifest1
-rw-r--r--app-office/onlyoffice-bin/onlyoffice-bin-8.2.1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-office/onlyoffice-bin/Manifest b/app-office/onlyoffice-bin/Manifest
index 16384e1b3a4b..2c58c6c36304 100644
--- a/app-office/onlyoffice-bin/Manifest
+++ b/app-office/onlyoffice-bin/Manifest
@@ -1,2 +1,3 @@
DIST onlyoffice-bin-8.1.1_amd64.deb 208387824 BLAKE2B 274cc27eb2a364fcc93c5363e38ac80db55e151ab3ff2e5f82fdd04dbab3f55f0facb7043ee67ab5324ac528811f723136498b8dae2390e2092af70ecb8be5d1 SHA512 883d87b1cb3936792bde01da018d838ada4e53796a7f2fdf07a21d592a1b8c190923b03a5c21408efceeba8665cfbe80c614a93e9d211a819780b6083583e5bd
DIST onlyoffice-bin-8.2.0_amd64.deb 286395820 BLAKE2B 28040305346b77d3b6493244795f8e8de98cddf814d7547565abb45c119acde7fe62ffc0cf01f29e3343a7c1e08114db49c54e02c574dc650121e59977fde07b SHA512 83a80d0da1004746957acce2e411fecd774872e2593c7b199580981a2b87327414e1a8b1104c98ffdec18a8554021f88038143491a7775e87afdd7e0fc1d61ab
+DIST onlyoffice-bin-8.2.1_amd64.deb 283141350 BLAKE2B 268e95c0f001b3b5c6e07023fd486fc22bf7434b3c0ec512162a797b04c3448a96d6106c6b0fd34aadf2a196c27985e81ff24b4abcafc8d6dd7ca7288ee9b102 SHA512 e74ac65ee8dda4c4bdb7fcf2a87c1bb678cecda98ad7f8859aa4408a2d118e59313c51020067dff89a1667054d51434881e0c76ade3d40b016ef5604cea7bac5
diff --git a/app-office/onlyoffice-bin/onlyoffice-bin-8.2.1.ebuild b/app-office/onlyoffice-bin/onlyoffice-bin-8.2.1.ebuild
new file mode 100644
index 000000000000..7cca4ae757b0
--- /dev/null
+++ b/app-office/onlyoffice-bin/onlyoffice-bin-8.2.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_P="ONLYOFFICE-DesktopEditors-"${PV}""
+
+DESCRIPTION="Onlyoffice is an office productivity suite (binary version)"
+HOMEPAGE="https://www.onlyoffice.com/"
+SRC_URI="
+ amd64? (
+ https://github.com/ONLYOFFICE/DesktopEditors/releases/download/v"${PV}"/onlyoffice-desktopeditors_amd64.deb
+ -> "${P}"_amd64.deb
+ )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip test"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5[eglfs]
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/libglvnd
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-devel/gcc
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ || (
+ media-libs/libpulse
+ media-sound/apulse
+ )
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Allow launching the ONLYOFFICE on ALSA systems via
+ # media-sound/apulse
+ sed -i -e 's|\(export LD_LIBRARY_PATH=$DIR$LDLPATH\)|\1:'"${EPREFIX}"'/usr/'$(get_libdir)'/apulse|' \
+ "${S}"/usr/bin/onlyoffice-desktopeditors || die
+}
+
+src_install() {
+ domenu usr/share/applications/onlyoffice-desktopeditors.desktop
+ for size in {16,24,32,48,64,128,256}; do
+ doicon -s ${size} usr/share/icons/hicolor/${size}x${size}/apps/onlyoffice-desktopeditors.png
+ done
+
+ dobin usr/bin/desktopeditors usr/bin/onlyoffice-desktopeditors
+ doins -r opt
+ fperms +x /opt/onlyoffice/desktopeditors/{DesktopEditors,editors_helper,converter/x2t}
+}