summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-07 15:59:12 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-07 15:59:12 +0100
commit764addedbd5fccd3ff9dc7f49a7eae7827b67095 (patch)
tree3470545ac3d4dbfcd646a30c35ff599827409e02 /app-office
parentsys-cluster/virtctl: restrict tests (diff)
downloadgentoo-764addedbd5fccd3ff9dc7f49a7eae7827b67095.tar.gz
gentoo-764addedbd5fccd3ff9dc7f49a7eae7827b67095.tar.bz2
gentoo-764addedbd5fccd3ff9dc7f49a7eae7827b67095.zip
app-office/orage: Bump to 4.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/orage/Manifest1
-rw-r--r--app-office/orage/orage-4.20.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-office/orage/Manifest b/app-office/orage/Manifest
index 2b18381ef034..d1611fd0a015 100644
--- a/app-office/orage/Manifest
+++ b/app-office/orage/Manifest
@@ -1 +1,2 @@
DIST orage-4.18.0.tar.bz2 1418645 BLAKE2B 533f55d4a6e69c0458fb01a8b3fd6a20f30b409ddd1d2eb65f00c321daa441d7e99e154ee4558160fc3e387e2ddb45a2ee0c37e6814a74f40e724fd748cd2fa5 SHA512 7760219f64ac3e2ba6d73541a626a0c9411b93268c007f2af5d8080a3a3c0b2a08e00dd96b7794b688aa83c567150c02033b9ba46bf38cd71d3d890e8d1e45ad
+DIST orage-4.20.0.tar.bz2 2326936 BLAKE2B 7729605ea09ef29f020564826729303c8f717acc4229d8a99347a2b112e1c3ab62e6b061ea58e82881e4aee3b5af61b9757bf229e8219c2b79c47427a55150bb SHA512 f1e66e048cdc817b2bc07585a3d28e4e8c3b58fa8b1b74bea4c3d72715ac90d66a4bf1532e726123c31ac8511888559b7c980dc3cbed099759e3cf17887fb7cd
diff --git a/app-office/orage/orage-4.20.0.ebuild b/app-office/orage/orage-4.20.0.ebuild
new file mode 100644
index 000000000000..fe6ed3aabf0e
--- /dev/null
+++ b/app-office/orage/orage-4.20.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A calendar application for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/apps/orage/start
+ https://gitlab.xfce.org/apps/orage/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.58.0
+ >=dev-libs/libical-3.0.16:=
+ >=x11-libs/gtk+-3.24.0:3=
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ >=dev-build/libtool-2.2.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}