summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-12 22:15:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-12 22:16:26 +0300
commit1cb70c0524ea25d15ee0070fc4e6f3891f0777c2 (patch)
tree9abe954e9a5b0a4dce292fc4af5669ab804e5d1f /app-office
parentsys-apps/iproute2: Remove split-usr again (diff)
downloadgentoo-1cb70c0524ea25d15ee0070fc4e6f3891f0777c2.tar.gz
gentoo-1cb70c0524ea25d15ee0070fc4e6f3891f0777c2.tar.bz2
gentoo-1cb70c0524ea25d15ee0070fc4e6f3891f0777c2.zip
app-office/lyx: remove USE=debug, restrict tests
USE=debug is bringing too much headache, really not worth. Also, the tests are broken upstream in a lot of places (and known), they use tests as more of report of progress, so no need to run this in Gentoo. Closes: https://bugs.gentoo.org/928672 Closes: https://bugs.gentoo.org/928670 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/lyx-2.4.0_rc4.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-office/lyx/lyx-2.4.0_rc4.ebuild b/app-office/lyx/lyx-2.4.0_rc4.ebuild
index 77bf28a6298f..f40e3e2a9aec 100644
--- a/app-office/lyx/lyx-2.4.0_rc4.ebuild
+++ b/app-office/lyx/lyx-2.4.0_rc4.ebuild
@@ -15,8 +15,9 @@ S=${WORKDIR}/${P/_rc/~RC}
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
-IUSE="aspell cups debug dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
+IUSE="aspell cups dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
RDEPEND="${PYTHON_DEPS}
app-text/mythes
@@ -118,17 +119,17 @@ src_configure() {
# external dependencies
-DLYX_EXTERNAL_Z=ON
-DLYX_EXTERNAL_ICONV=ON
- -DLYX_EXTERNAL_HUNSPELL=$(usex !debug)
- -DLYX_EXTERNAL_MYTHES=$(usex !debug ON OFF)
- -DLYX_EXTERNAL_BOOST=$(usex !debug)
+ -DLYX_EXTERNAL_HUNSPELL=ON
+ -DLYX_EXTERNAL_MYTHES=ON
+ -DLYX_EXTERNAL_BOOST=ON
-DLYX_PROGRAM_SUFFIX=OFF
# debug control
-DLYX_NO_OPTIMIZE=OFF
- -DLYX_RELEASE=$(usex !debug)
- -DLYX_DEBUG=$(usex debug)
- -DLYX_DEBUG_GLIBC=$(usex debug)
- -DLYX_STDLIB_DEBUG=$(usex debug)
+ -DLYX_RELEASE=ON
+ -DLYX_DEBUG=OFF
+ -DLYX_DEBUG_GLIBC=OFF
+ -DLYX_STDLIB_DEBUG=OFF
)
cmake_src_configure