summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-09 22:09:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-10 01:04:33 +0100
commit05c841fbf1f173837c1078ebf9b1ae076317413f (patch)
tree81b33710377d488e47a8b743ec8bfea82c48b7a8 /app-office
parentapp-emacs/compat: update metadata xml (diff)
downloadgentoo-05c841fbf1f173837c1078ebf9b1ae076317413f.tar.gz
gentoo-05c841fbf1f173837c1078ebf9b1ae076317413f.tar.bz2
gentoo-05c841fbf1f173837c1078ebf9b1ae076317413f.zip
app-office/libreoffice: backport patch for >=zxing-cpp-1.4.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.3.7.2-zxing-cpp-1.4.0.patch59
-rw-r--r--app-office/libreoffice/libreoffice-7.3.7.2.ebuild5
-rw-r--r--app-office/libreoffice/libreoffice-7.4.3.2.ebuild7
-rw-r--r--app-office/libreoffice/libreoffice-7.4.4.2.ebuild15
-rw-r--r--app-office/libreoffice/libreoffice-7.4.9999.ebuild15
5 files changed, 82 insertions, 19 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.3.7.2-zxing-cpp-1.4.0.patch b/app-office/libreoffice/files/libreoffice-7.3.7.2-zxing-cpp-1.4.0.patch
new file mode 100644
index 000000000000..52b383a9d3e9
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.3.7.2-zxing-cpp-1.4.0.patch
@@ -0,0 +1,59 @@
+From 15e5d86cc55ad94ac946e04d5e25b84be5810970 Mon Sep 17 00:00:00 2001
+From: "Brett T. Warden" <brett.t.warden@intel.com>
+Date: Fri, 30 Dec 2022 08:43:25 +0100
+Subject: Remove dependency on BitArray.h from zxing-1.2.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In zxing-1.4.0, numerous headers are no longer public. Rework the
+ConvertToSVGFormat method so it uses bitmatrix.get instead of
+bitmatrix.getRow, similar to the ToSVG method in zxing itself.
+
+See https://github.com/zxing-cpp/zxing-cpp/issues/361
+
+Change-Id: Ie25eb8f782e8799fbd57c24ef79bba92acf0f9ff
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/144874
+Tested-by: René Engelhard <rene@debian.org>
+Reviewed-by: René Engelhard <rene@debian.org>
+Tested-by: Jenkins
+Reviewed-by: Caolán McNamara <caolanm@redhat.com>
+---
+ cui/source/dialogs/QrCodeGenDialog.cxx | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/cui/source/dialogs/QrCodeGenDialog.cxx b/cui/source/dialogs/QrCodeGenDialog.cxx
+index f8cbac1d758d..817be7f21ede 100644
+--- a/cui/source/dialogs/QrCodeGenDialog.cxx
++++ b/cui/source/dialogs/QrCodeGenDialog.cxx
+@@ -27,7 +27,6 @@
+ #endif
+
+ #include <BarcodeFormat.h>
+-#include <BitArray.h>
+ #include <BitMatrix.h>
+ #include <MultiFormatWriter.h>
+ #include <TextUtfEncoding.h>
+@@ -79,7 +78,6 @@ OString ConvertToSVGFormat(const ZXing::BitMatrix& bitmatrix)
+ OStringBuffer sb;
+ const int width = bitmatrix.width();
+ const int height = bitmatrix.height();
+- ZXing::BitArray row(width);
+ sb.append("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<svg xmlns=\"http://www.w3.org/2000/svg\" version=\"1.1\" viewBox=\"0 0 "
+ + OString::number(width) + " " + OString::number(height)
+@@ -87,10 +85,9 @@ OString ConvertToSVGFormat(const ZXing::BitMatrix& bitmatrix)
+ "<path d=\"");
+ for (int i = 0; i < height; ++i)
+ {
+- bitmatrix.getRow(i, row);
+ for (int j = 0; j < width; ++j)
+ {
+- if (row.get(j))
++ if (bitmatrix.get(j, i))
+ {
+ sb.append("M" + OString::number(j) + "," + OString::number(i) + "h1v1h-1z");
+ }
+--
+cgit v1.2.1
+
diff --git a/app-office/libreoffice/libreoffice-7.3.7.2.ebuild b/app-office/libreoffice/libreoffice-7.3.7.2.ebuild
index 9f590961fe49..94e96a188830 100644
--- a/app-office/libreoffice/libreoffice-7.3.7.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -295,8 +295,9 @@ PATCHES=(
# 7.4 branch
"${FILESDIR}/${PN}-7.3.5.2-gpgme-1.18.0.patch"
- # backport
+ # 7.5 branch
"${FILESDIR}/${P}-boost-1.81-locale.patch"
+ "${FILESDIR}/${P}-zxing-cpp-1.4.0.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/app-office/libreoffice/libreoffice-7.4.3.2.ebuild b/app-office/libreoffice/libreoffice-7.4.3.2.ebuild
index 8850d76c0403..79f088c899db 100644
--- a/app-office/libreoffice/libreoffice-7.4.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.4.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -96,14 +96,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
libreoffice_extensions_wiki-publisher? ( java )
"
-RESTRICT="!test? ( test )"
-
LICENSE="|| ( LGPL-3 MPL-1.1 )"
SLOT="0"
[[ ${MY_PV} == *9999* ]] || \
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
+RESTRICT="!test? ( test )"
+
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
@@ -296,6 +296,7 @@ PATCHES=(
# 7.5 branch
"${FILESDIR}/${PN}-7.3.7.2-boost-1.81-locale.patch"
+ "${FILESDIR}/${PN}-7.3.7.2-zxing-cpp-1.4.0.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/app-office/libreoffice/libreoffice-7.4.4.2.ebuild b/app-office/libreoffice/libreoffice-7.4.4.2.ebuild
index 9a4e143d2efb..45f0f59276d6 100644
--- a/app-office/libreoffice/libreoffice-7.4.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.4.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -79,6 +79,12 @@ SRC_URI+=" ${ADDONS_SRC[*]}"
unset ADDONS_URI
unset ADDONS_SRC
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+
+#[[ ${MY_PV} == *9999* ]] || \
+#KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
+
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
@@ -98,12 +104,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
RESTRICT="!test? ( test )"
-LICENSE="|| ( LGPL-3 MPL-1.1 )"
-SLOT="0"
-
-#[[ ${MY_PV} == *9999* ]] || \
-#KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
-
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
@@ -296,6 +296,7 @@ PATCHES=(
# 7.5 branch
"${FILESDIR}/${PN}-7.3.7.2-boost-1.81-locale.patch"
+ "${FILESDIR}/${PN}-7.3.7.2-zxing-cpp-1.4.0.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/app-office/libreoffice/libreoffice-7.4.9999.ebuild b/app-office/libreoffice/libreoffice-7.4.9999.ebuild
index 9a4e143d2efb..45f0f59276d6 100644
--- a/app-office/libreoffice/libreoffice-7.4.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -79,6 +79,12 @@ SRC_URI+=" ${ADDONS_SRC[*]}"
unset ADDONS_URI
unset ADDONS_SRC
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+
+#[[ ${MY_PV} == *9999* ]] || \
+#KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
+
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
@@ -98,12 +104,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
RESTRICT="!test? ( test )"
-LICENSE="|| ( LGPL-3 MPL-1.1 )"
-SLOT="0"
-
-#[[ ${MY_PV} == *9999* ]] || \
-#KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
-
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
@@ -296,6 +296,7 @@ PATCHES=(
# 7.5 branch
"${FILESDIR}/${PN}-7.3.7.2-boost-1.81-locale.patch"
+ "${FILESDIR}/${PN}-7.3.7.2-zxing-cpp-1.4.0.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"