summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-14 13:49:30 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-14 13:49:36 +0200
commit757a819ce91149d21530678b1b8af93c0cd64795 (patch)
tree5eeff907feafb101744d47d262095a85389a25ff /app-office/lyx
parentapp-office/lyx: enable py3.11 (diff)
downloadgentoo-757a819ce91149d21530678b1b8af93c0cd64795.tar.gz
gentoo-757a819ce91149d21530678b1b8af93c0cd64795.tar.bz2
gentoo-757a819ce91149d21530678b1b8af93c0cd64795.zip
app-office/lyx: add 2.3.7
Also makes dev-texlive/texlive-fontsextra in favor of a warning of some fonts being missing if not installed. Closes: https://bugs.gentoo.org/653808 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.3.7.ebuild188
2 files changed, 189 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index 3c560e71a9cd..8ac01ca306a7 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1 +1,2 @@
DIST lyx-2.3.6.1.tar.xz 16242608 BLAKE2B d59c6db79d7760902f93405e3737974fa9c6bd79c5ab4b02010021532903c76a77701f1f99a0838b4379c548f3f37dcdd9eeb492b733c4162162d868d1d92970 SHA512 233f6c54d4a036ad12f33c6705810bfb99747bdbd015550a8a0a9d7b664d3be50a06dc337191b820c42de4407c5f790efa50c706a45fb2260a71f772fb22c872
+DIST lyx-2.3.7-1.tar.xz 16158416 BLAKE2B 6041280ab0cd4dfa3c10e8ae01253ff657b4ac9ffe4cf61a3a2459b7aef152a7daf8ae306a09aaece799b6e7b6b15bc1aff62ab0f5d46508fbd79fd3e0b1c45b SHA512 b8aaefb68993032354fea3c6fd87d6da161395c92b5def4ecf92a7d6873ec59e01cdfb45c51ae1aaa62aa54db8e100b00ff9c2c9e0f1307c2f46860cd8c6eefe
diff --git a/app-office/lyx/lyx-2.3.7.ebuild b/app-office/lyx/lyx-2.3.7.ebuild
new file mode 100644
index 000000000000..8a46110805a0
--- /dev/null
+++ b/app-office/lyx/lyx-2.3.7.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+MY_P="${P/_}"
+inherit desktop font optfeature python-single-r1 qmake-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="WYSIWYM (What You See Is What You Mean) document processor based on LaTeX"
+HOMEPAGE="https://www.lyx.org/"
+SRC_URI="http://ftp.lyx.org/pub/lyx/stable/2.3.x/${MY_P}-1.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="aspell cups debug dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# bc needed http://comments.gmane.org/gmane.editors.lyx.devel/137498 and bug #787839
+BDEPEND="
+ sys-devel/bc
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${PYTHON_DEPS}
+ app-text/mythes
+ dev-libs/boost:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/file
+ sys-libs/zlib
+ virtual/imagemagick-tools[png,svg?]
+
+ x11-misc/xdg-utils
+
+ aspell? ( app-text/aspell )
+ cups? ( net-print/cups )
+ dia? ( app-office/dia )
+ dot? ( media-gfx/graphviz )
+ enchant? ( app-text/enchant:2 )
+ gnumeric? ( app-office/gnumeric )
+ html? ( dev-tex/html2latex )
+ hunspell? ( app-text/hunspell )
+ l10n_he? ( dev-tex/culmus-latex )
+ latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ app-text/ps2eps
+ app-text/texlive
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-plaingeneric
+ || (
+ dev-tex/hevea
+ dev-tex/latex2html
+ dev-tex/tex4ht[java]
+ dev-tex/tth
+ )
+ )
+ rcs? ( dev-vcs/rcs )
+ rtf? (
+ app-text/unrtf
+ dev-tex/html2latex
+ dev-tex/latex2rtf
+ )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+S="${WORKDIR}/${MY_P}"
+
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+
+PATCHES=(
+ # Try first with xdg-open before hardcoded commands
+ # Patch from Debian using a similar approach to Fedora
+ "${FILESDIR}"/${PN}-prefer-xdg-open.patch
+
+ # Already part of 2.4.x (from Fedora)
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1965118
+ "${FILESDIR}"/${PN}-2.3.6.1-python.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS="${T}"/fonts
+
+ econf \
+ $(use_with aspell) \
+ $(use_enable debug) \
+ $(use_with enchant) \
+ $(use_with hunspell) \
+ $(use_enable monolithic-build) \
+ $(use_enable nls) \
+ --enable-qt5 \
+ --with-qt-dir=$(qt5_get_libdir)/qt5 \
+ --disable-stdlib-debug \
+ --without-included-boost \
+ --with-packaging=posix
+}
+
+src_install() {
+ default
+
+ if use l10n_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind || die
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind || die
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind
+ fi
+
+ newicon -s 32 "development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "lib/images/lyx.png"
+ doicon -s scalable "lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym ../myspell /usr/share/lyx/dicts
+ dosym ../myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash || die
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use l10n_he || has he ${LINGUAS} || has ar ${LINGUAS} ; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+
+ optfeature "handling more fonts" dev-texlive/texlive-fontsextra
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ if use latex ; then
+ texhash || die
+ fi
+}