summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/libalkimia
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/libalkimia')
-rw-r--r--app-office/libalkimia/Manifest1
-rw-r--r--app-office/libalkimia/files/libalkimia-4.3.2-doc.patch34
-rw-r--r--app-office/libalkimia/libalkimia-4.3.2-r1.ebuild28
-rw-r--r--app-office/libalkimia/metadata.xml5
4 files changed, 68 insertions, 0 deletions
diff --git a/app-office/libalkimia/Manifest b/app-office/libalkimia/Manifest
new file mode 100644
index 000000000000..8099ce9b8790
--- /dev/null
+++ b/app-office/libalkimia/Manifest
@@ -0,0 +1 @@
+DIST 137323-libalkimia-4.3.2.tar.bz2 32687 SHA256 64379af992d5548a6757495f47568ebf8cb859a868ced8b5d3d5975f4dfcebdc SHA512 fb04e7bf6d01f9fc54cccc63f0b41c28e28a6844eec1e65c057c7dde599a58cb1f173dd012aca995280581d47e3419b59e0d070f649de0e4b1dd92cd4af4c2b2 WHIRLPOOL d022dcc647abb24ed5416d07d7e4e8bc9a8dfb72371ebf5533d49c35892f2116544f6852e7391103c1eb373f18d9070ccc8a80ff1cffaac12bd8db4d46914393
diff --git a/app-office/libalkimia/files/libalkimia-4.3.2-doc.patch b/app-office/libalkimia/files/libalkimia-4.3.2-doc.patch
new file mode 100644
index 000000000000..c88b95b65269
--- /dev/null
+++ b/app-office/libalkimia/files/libalkimia-4.3.2-doc.patch
@@ -0,0 +1,34 @@
+diff -ruN libalkimia-4.3.1.orig/libalkimia/CMakeLists.txt libalkimia-4.3.1/libalkimia/CMakeLists.txt
+--- libalkimia-4.3.1.orig/libalkimia/CMakeLists.txt 2011-08-01 12:14:46.000000000 +0200
++++ libalkimia-4.3.1/libalkimia/CMakeLists.txt 2011-08-01 23:04:41.000000000 +0200
+@@ -86,6 +86,8 @@
+ endif(NOT WIN32)
+ ########### documentation ###################
+
++if(BUILD_DOC)
++
+ # check for Doxygen
+ find_package(Doxygen)
+ if(DOXYGEN_FOUND)
+@@ -95,9 +97,20 @@
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libalkimia.doxygen.in ${CMAKE_CURRENT_BINARY_DIR}/libalkimia.doxygen IMMEDIATE)
+
+- add_custom_target(libalkimia_apidoc ${DOXYGEN} ${CMAKE_CURRENT_BINARY_DIR}/libalkimia.doxygen)
++ add_custom_target(libalkimia_apidoc ALL ${DOXYGEN} ${CMAKE_CURRENT_BINARY_DIR}/libalkimia.doxygen)
++else(DOXYGEN_FOUND)
++ MESSAGE(FATAL_ERROR "API documentation requested but doxygen not found")
+ endif(DOXYGEN_FOUND)
+
++ELSE(BUILD_DOC)
++
++ MESSAGE(STATUS "")
++ MESSAGE(STATUS "Documentation will NOT be installed")
++ MESSAGE(STATUS "Because the option -DBUILD_DOC=ON wasn't passed to cmake")
++ MESSAGE(STATUS "")
++
++ENDIF(BUILD_DOC)
++
+ ########### tests ###################
+
+ set( alkvaluetest_SRCS alkvaluetest.cpp )
diff --git a/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild b/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..908004e82d02
--- /dev/null
+++ b/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Library with common classes and functionality used by KDE finance applications"
+HOMEPAGE="http://kde-apps.org/content/show.php/libalkimia?content=137323"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/137323-${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${PN}-4.3.2-doc.patch" )
+
+src_configure() {
+ mycmakeargs=( $(cmake-utils_use_build doc) )
+ kde4-base_src_configure
+}
diff --git a/app-office/libalkimia/metadata.xml b/app-office/libalkimia/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/app-office/libalkimia/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>