summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/calcurse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/calcurse')
-rw-r--r--app-office/calcurse/Manifest2
-rw-r--r--app-office/calcurse/calcurse-3.1.4.ebuild24
-rw-r--r--app-office/calcurse/calcurse-3.2.1.ebuild24
-rw-r--r--app-office/calcurse/files/calcurse-3.1.4-tinfo.patch21
-rw-r--r--app-office/calcurse/metadata.xml12
5 files changed, 83 insertions, 0 deletions
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
new file mode 100644
index 000000000000..db08757c2f96
--- /dev/null
+++ b/app-office/calcurse/Manifest
@@ -0,0 +1,2 @@
+DIST calcurse-3.1.4.tar.gz 684526 SHA256 4121b3b14ded3583af7613a99646332701ee2ccc8cf2b87397eb3c07b97390e3 SHA512 efdb655f96a176ca45a23a6246987735413a69046e5273efafffd5d2087f880969f84e387dd84672dacc8fae670a86ee7b132f6a4662e072ba92121492fd7ca7 WHIRLPOOL cc0802f6128068419de98524fcd984cf3213ca7f7f2cc003b122c808aed858230a87f387682368379329d0205bb42a55d232e5cf82f639535ffdda8ab51d9fa7
+DIST calcurse-3.2.1.tar.gz 606098 SHA256 05d5516808f98eee3d1eb8d379aa88cb24afc2b7a3eac046e46247013a61223d SHA512 1aaba75144d4da4caf48f0ff566efc0fe4977e41be0f929b4f13611c12fc849da2185fd132f93723aefc8b965eb4ee6fe2f20eb05d3eecd094891841d613c0df WHIRLPOOL a1c93608aaf136188776993663de757ea4193c6cbbe5c837bc74a7ae5564bad1682b6c4a9f96db106532b4338104859da96b4fdccb2c34963c1e9a1c310517d2
diff --git a/app-office/calcurse/calcurse-3.1.4.ebuild b/app-office/calcurse/calcurse-3.1.4.ebuild
new file mode 100644
index 000000000000..45bc6cc4170b
--- /dev/null
+++ b/app-office/calcurse/calcurse-3.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="http://calcurse.org/"
+SRC_URI="http://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
diff --git a/app-office/calcurse/calcurse-3.2.1.ebuild b/app-office/calcurse/calcurse-3.2.1.ebuild
new file mode 100644
index 000000000000..cdc81ff59cff
--- /dev/null
+++ b/app-office/calcurse/calcurse-3.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="http://calcurse.org/"
+SRC_URI="http://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.4-tinfo.patch
+ eautoreconf
+}
diff --git a/app-office/calcurse/files/calcurse-3.1.4-tinfo.patch b/app-office/calcurse/files/calcurse-3.1.4-tinfo.patch
new file mode 100644
index 000000000000..f3d2aac897e9
--- /dev/null
+++ b/app-office/calcurse/files/calcurse-3.1.4-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,7 @@
+ #-------------------------------------------------------------------------------
+ AC_PREREQ(2.59)
+ AC_INIT([calcurse],
+- m4_esyscmd([build-aux/git-version-gen .version]),
++ m4_esyscmd_s([cat .version]),
+ [bugs@calcurse.org])
+ AM_INIT_AUTOMAKE
+ #m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+@@ -51,6 +51,9 @@
+ LIBS="$LIBS -l$available_ncurses"
+ ])
+
++AC_SEARCH_LIBS([cbreak], [tinfow tinfo],,
++ AC_MSG_ERROR([Cannot find a library providing cbreak]))
++
+ AC_CHECK_HEADERS([pthread.h], [
+ AC_CHECK_LIB(pthread, pthread_create, [
+ LIBS="$LIBS -pthread"
diff --git a/app-office/calcurse/metadata.xml b/app-office/calcurse/metadata.xml
new file mode 100644
index 000000000000..10edd3d80584
--- /dev/null
+++ b/app-office/calcurse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>Calcurse is a text-based personal organizer which helps keeping
+track of events and everyday tasks. It contains a calendar, a 'todo' list, and
+puts your appointments in order. The user interface is configurable, and one can
+choose between different color schemes and layouts. All of the commands are
+documented within an online help system.</longdescription>
+</pkgmetadata>