summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-01-02 10:46:57 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-01-02 10:49:32 +0200
commitf9a5b8125cc689047173ab1015e57b50dfb07e56 (patch)
treeae13c3e8add4d3d7f87a4c136419a02845bac23a /app-misc
parentmedia-sound/mpd: Stabilize 0.23.13 x86, #921179 (diff)
downloadgentoo-f9a5b8125cc689047173ab1015e57b50dfb07e56.tar.gz
gentoo-f9a5b8125cc689047173ab1015e57b50dfb07e56.tar.bz2
gentoo-f9a5b8125cc689047173ab1015e57b50dfb07e56.zip
app-misc/fastfetch: Fix compilation with direct X headers
Closes: https://bugs.gentoo.org/921175 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fastfetch/fastfetch-2.5.0.ebuild1
-rw-r--r--app-misc/fastfetch/files/fastfetch-2.5.0-nvidia2.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/app-misc/fastfetch/fastfetch-2.5.0.ebuild b/app-misc/fastfetch/fastfetch-2.5.0.ebuild
index 8facae65cd7b..e128b570ad48 100644
--- a/app-misc/fastfetch/fastfetch-2.5.0.ebuild
+++ b/app-misc/fastfetch/fastfetch-2.5.0.ebuild
@@ -64,6 +64,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}"/${P}-nvidia.patch
+ "${FILESDIR}"/${P}-nvidia2.patch
)
src_configure() {
diff --git a/app-misc/fastfetch/files/fastfetch-2.5.0-nvidia2.patch b/app-misc/fastfetch/files/fastfetch-2.5.0-nvidia2.patch
new file mode 100644
index 000000000000..5f256a61a34d
--- /dev/null
+++ b/app-misc/fastfetch/files/fastfetch-2.5.0-nvidia2.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/921175
+
+--- a/src/detection/gpu/gpu_wsl.cpp
++++ b/src/detection/gpu/gpu_wsl.cpp
+@@ -98,6 +98,7 @@ const char* ffGPUDetectByDirectX(FF_MAYBE_UNUSED const FFGPUOptions* options, FF
+ const char* vendorStr = ffGetGPUVendorString((unsigned) hardwareId.vendorID);
+ ffStrbufSetStatic(&gpu->vendor, vendorStr);
+
++ #ifdef FF_HAVE_NVIDIA_GPU
+ if (vendorStr == FF_GPU_VENDOR_NAME_NVIDIA && (options->driverSpecific || options->temp))
+ {
+ FFGpuDriverCondition cond = {
+@@ -117,6 +118,7 @@ const char* ffGPUDetectByDirectX(FF_MAYBE_UNUSED const FFGPUOptions* options, FF
+ .frequency = &gpu->frequency,
+ }, "/usr/lib/wsl/lib/libnvidia-ml.so");
+ }
++ #endif
+ }
+ }
+