summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2021-10-07 10:22:09 +0200
committerAmy Liffey <amynka@gentoo.org>2021-10-07 10:22:09 +0200
commitd51ef5ca4d38e8a034657790272464287f915e54 (patch)
tree7a7e6590634a4018cbee963444e4e66cc082424d /app-misc
parentnet-libs/libwebsockets: Update subslot (diff)
downloadgentoo-d51ef5ca4d38e8a034657790272464287f915e54.tar.gz
gentoo-d51ef5ca4d38e8a034657790272464287f915e54.tar.bz2
gentoo-d51ef5ca4d38e8a034657790272464287f915e54.zip
app-misc/libdatovka: version bump 0.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/libdatovka/Manifest1
-rw-r--r--app-misc/libdatovka/libdatovka-0.2.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-misc/libdatovka/Manifest b/app-misc/libdatovka/Manifest
index 50b98c566519..368eeaa13b6e 100644
--- a/app-misc/libdatovka/Manifest
+++ b/app-misc/libdatovka/Manifest
@@ -1 +1,2 @@
DIST libdatovka-0.1.2.tar.xz 672348 BLAKE2B 34fd0e3651fd468c96c99d261b199cb25b5d6ac46ae19f96b29c62037acdd7a0a053a5098f317da2dc31b27df7879839163dfe1a109877ed61880723b429a626 SHA512 2c9bf9f7a2166582d8757b1811031cc3501872baad1ec901799253036bbf5e33a059cd3310e6798e4e248b41c92f4775ab3fad90a97648eee5afece8203bc827
+DIST libdatovka-0.2.0.tar.xz 677232 BLAKE2B f5545d28095d5c32a389293a5ef3e8e22f475ffcf3268ecb210271ab857b813aa1e710f853b6ded9b5b1dc60c57ff9c10e1b28b132f516f31921b213d16f496f SHA512 3e321afa4a64edcdc3bb112ceebcb6736efad547aa6c033af767e40dc962114a8b4c9ccec8e9fb5cce82a6c5f3e251012f1db355d4b4b9e5e519ab8466b884e0
diff --git a/app-misc/libdatovka/libdatovka-0.2.0.ebuild b/app-misc/libdatovka/libdatovka-0.2.0.ebuild
new file mode 100644
index 000000000000..456af2ddfada
--- /dev/null
+++ b/app-misc/libdatovka/libdatovka-0.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Client library for accessing ISDS SOAP services"
+HOMEPAGE="https://www.datovka.cz/cs/pages/libdatovka.html"
+SRC_URI="https://secure.nic.cz/files/datove_schranky/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug doc nls openssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gnupg
+ app-crypt/gpgme
+ dev-libs/libgcrypt:=
+ )"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --disable-static
+ $(use_with curl libcurl)
+ $(use_enable curl curlreauthorizationbug)
+ $(use_enable doc)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable openssl openssl-backend)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}