summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-09 10:13:38 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-09 10:14:41 +0300
commit4e8c83ecee62fb15436dc7d9986be893ea16e164 (patch)
tree65f18a4e9d449c564ecd37f1e8cbf57092ddae0c /app-misc
parentnet-misc/turbovnc: drop 3.1 (diff)
downloadgentoo-4e8c83ecee62fb15436dc7d9986be893ea16e164.tar.gz
gentoo-4e8c83ecee62fb15436dc7d9986be893ea16e164.tar.bz2
gentoo-4e8c83ecee62fb15436dc7d9986be893ea16e164.zip
app-misc/mc: add 4.8.32_rc1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mc/Manifest1
-rw-r--r--app-misc/mc/mc-4.8.32_rc1.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/app-misc/mc/Manifest b/app-misc/mc/Manifest
index 821186c1f709..acba57839f87 100644
--- a/app-misc/mc/Manifest
+++ b/app-misc/mc/Manifest
@@ -1,2 +1,3 @@
DIST mc-4.8.30.tar.xz 2380824 BLAKE2B 2bf759314abae39db7596426cba22f6eaac0efc58e7025f1a7ef1863496ea7a3c00d298d101123b9defb109e76e31fe988227fb5c1112e06051b3c7a5b3dc1b6 SHA512 f793f744eaff236c9952d477236dd775a24d9ddd7ff46940bfe2d06da5596bed91d6bd9c85250696da6dcdc0a1890dc01c736654df3f59039674eff38e12e68e
DIST mc-4.8.31.tar.xz 2385632 BLAKE2B aa8406d7d68a7466f662f83730dfc157f6e4f444b62284d9b71ea12def333996e298352f94526a3eb85491030f62373cf8d5621e449a7abf1fb5267a13a396fe SHA512 dc2272a0016ed782eafc78efda575b04d064ffa7984a146f3389dea81f4c7886647e7d1f097b547f7ae00190c10e35979a24400a6bb936c023f190a82934c12d
+DIST mc-4.8.32_rc1.tar.gz 3072991 BLAKE2B e22cf90530abe7240017688c5659eae14e3bb4d495a61f93c15f00be65459e4cf1ce19b82def55a8c03bf40ca196597cbdf029b55aa1b6542ef4b467355f65a0 SHA512 d9377cfe9214d7a585cf817cf843f4b7238c7d16051c8e19490b5b2786a1e407fa7d500bcb072b8a0ccc5f51bc610778e62091c9cf2f94cd96846dd0f3e44611
diff --git a/app-misc/mc/mc-4.8.32_rc1.ebuild b/app-misc/mc/mc-4.8.32_rc1.ebuild
new file mode 100644
index 000000000000..cbd7e1512974
--- /dev/null
+++ b/app-misc/mc/mc-4.8.32_rc1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_P="${P/_/-}"
+MY_PV="${PV/_rc/-pre}"
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="https://midnight-commander.org"
+SRC_URI="https://github.com/MidnightCommander/mc/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+edit gpm sftp +slang spell test unicode X"
+
+REQUIRED_USE="spell? ( edit )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.30.0:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs[tools(+)] )
+ sftp? ( net-libs/libssh2 )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses:=[unicode(+)?] )
+ spell? ( app-text/aspell )
+ X? (
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+ spell? ( app-dicts/aspell-en )
+"
+
+# Force nls so xgettext is installed. Will revert this.
+BDEPEND="
+ sys-devel/gettext
+ app-arch/xz-utils
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.26-ncurses-mouse.patch
+ "${FILESDIR}"/${PN}-4.8.29-gentoo-tools.patch
+)
+
+# This is a check for AIX, on Linux mc uses statvfs() regardless of whether
+# LFS64 interfaces are available in libc or not.
+QA_CONFIG_IMPL_DECL_SKIP=(
+ statvfs64
+)
+
+src_prepare() {
+ default
+
+ # Bug #906194, #922483
+ if use elibc_musl; then
+ eapply "${FILESDIR}"/${PN}-4.8.30-musl-tests.patch
+ eapply "${FILESDIR}"/${PN}-4.8.31-musl-tests.patch
+ fi
+
+ eautoreconf
+
+ # Copied from autogen.sh
+ xgettext --keyword=_ --keyword=N_ --keyword=Q_ --output=- \
+ `find . -name '*.[ch]'` | sed -ne '/^#:/{s/#://;s/:[0-9]*/\
+/g;s/ //g;p;}' | \
+ grep -v '^$' | sort | uniq >po/POTFILES.in || die
+
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local myeconfargs=(
+ --enable-charset
+ --enable-vfs
+ --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
+ $(use_enable kernel_linux vfs-undelfs)
+ # Today mclib does not expose any headers and is linked to
+ # single 'mc' binary. Thus there is no advantage of having
+ # a library. Let's avoid shared library altogether
+ # as it also conflicts with sci-libs/mc: bug #685938
+ --disable-mclib
+ --enable-nls
+ $(use_enable sftp vfs-sftp)
+ $(use_enable spell aspell)
+ $(use_enable test tests)
+ $(use_with gpm gpm-mouse)
+ $(use_with X x)
+ $(use_with edit internal-edit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Bug #759466
+ if [[ ${EUID} == 0 ]] ; then
+ ewarn "You are emerging ${PN} as root with 'userpriv' disabled."
+ ewarn "Expect some test failures, or emerge with 'FEATURES=userpriv'!"
+ fi
+
+ # This test fails. Disable for now
+ # https://midnight-commander.org/ticket/4567
+ rm tests/src/vfs/extfs/helpers-list/data/iso9660.xorriso.* || die
+
+ # CK_FORK=no to avoid using fork() in check library
+ # as mc mocks fork() itself: bug #644462.
+ #
+ # VERBOSE=1 to make test failures contain detailed
+ # information.
+ CK_FORK=no emake check VERBOSE=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+}
+
+pkg_postinst() {
+ elog "${PN} extension scripts depend on many external tools, install them as needed"
+ elog
+ if use spell && ! has_version app-dicts/aspell-en ; then
+ elog "'spell' USE flag is enabled however app-dicts/aspell-en is not installed."
+ elog "You should manually set 'spell_language' in the Misc section of ~/.config/mc/ini"
+ elog "It has to be set to one of your installed aspell dictionaries or 'NONE'"
+ elog
+ fi
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}