summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2021-05-09 19:17:11 -0700
committerJoonas Niilola <juippis@gentoo.org>2021-06-07 08:27:47 +0300
commitfb0c00127cdc7b45a1e101c442f0403749b17258 (patch)
tree739a5ca42515e3540778b9b24f781b1d26fe46a3 /app-misc/trash-cli
parentnet-dns/maradns: version bump to 3.5.0020 and fixes (diff)
downloadgentoo-fb0c00127cdc7b45a1e101c442f0403749b17258.tar.gz
gentoo-fb0c00127cdc7b45a1e101c442f0403749b17258.tar.bz2
gentoo-fb0c00127cdc7b45a1e101c442f0403749b17258.zip
app-misc/trash-cli: Bump to 0.21.5.25
Closes: https://bugs.gentoo.org/791538 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/trash-cli')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.21.5.25.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 0abaeb5f7fe4..9c1919a166b4 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,2 +1,3 @@
DIST trash-cli-0.20.11.23.tar.gz 69229 BLAKE2B f3650a037f00e6ce8cd7bd1ff5f3e11c794ceb09563193e2930eb9b81cd40120dd48f117e8c96d900a8221db9a68360ff633e591367bd544ad07045b1a505304 SHA512 d370687da706677de61c0d234d4cb4db4ff4d9da8cde60c361d11eaccf319e2e418969a7d49ec6edd456524b1275b63d1fcd49bc9a9012afabda1c7a8ad7de78
DIST trash-cli-0.20.12.26.tar.gz 74542 BLAKE2B 558e3cc043cdaef44bf68317e666c6f757daf9feeb6b731a57aba91ec983e1adb1e404f7e8428a7bd1225d83df6e94e8b9b793942bbb233f09a44127af0a42fa SHA512 d0b0a97014c888ddda95759dc82837385a2809cae04bdf6a84dcf0233dc2cf9370253110bc5fdbc5c4452ebb65c5e7836fe1cfaa9aaabe38d34269724456cd1c
+DIST trash-cli-0.21.5.25.tar.gz 77067 BLAKE2B 5db46b21ba33b9076ea7f024b93e62f30b3671f44a024b30013369607bd580f0ef9831debd9fdc6c64575ab6edde14aa921229bbd16a6a77657b7ed20b58c318 SHA512 75ef338b356048768febc4afd42933d8aa44cde5156e386968dad7b33033b84becaef3d39ccf15c02216394735f37d1c7c8cd499000068d51247710e87590507
diff --git a/app-misc/trash-cli/trash-cli-0.21.5.25.ebuild b/app-misc/trash-cli/trash-cli-0.21.5.25.ebuild
new file mode 100644
index 000000000000..77b7ce756f95
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.21.5.25.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose