summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-21 16:52:03 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-21 17:23:43 -0700
commitedb422216b2a0d2f48fc5aae8fb39ce619bcf8e2 (patch)
treebf3ec880e394e85573674a84c4e46fc71e2ff8c1 /app-misc/tracker
parentx11-themes/gnome-backgrounds: Version bump to 42.0 (diff)
downloadgentoo-edb422216b2a0d2f48fc5aae8fb39ce619bcf8e2.tar.gz
gentoo-edb422216b2a0d2f48fc5aae8fb39ce619bcf8e2.tar.bz2
gentoo-edb422216b2a0d2f48fc5aae8fb39ce619bcf8e2.zip
app-misc/tracker: Version bump to 3.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/tracker')
-rw-r--r--app-misc/tracker/Manifest1
-rw-r--r--app-misc/tracker/tracker-3.3.0.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/app-misc/tracker/Manifest b/app-misc/tracker/Manifest
index c8d26bbd6ea1..0273c2755643 100644
--- a/app-misc/tracker/Manifest
+++ b/app-misc/tracker/Manifest
@@ -1,2 +1,3 @@
DIST tracker-2.3.6.tar.xz 1606716 BLAKE2B ea39df4438e4502bc0229a5cc3b42a2fe6e13a643ac8e4034004b1291da49ff3ad1a177227035a4a02fd8f3723a735d37371c898bb03a6fc10573606a1c29d70 SHA512 1b8ae06b6c64a0cbe7d4c987bafe392fb38014215fc698f919273ba1f422dd0bc24344d3fd73164b00bfea315e527e2886ba90f1f1b86d5fceff24455b36d67e
DIST tracker-3.2.1.tar.xz 1947304 BLAKE2B 9095a457157cd2bedfd34b01afc9fd832af0a5c57c6ba5b9c00175f382b70135e20437d6fd2ca9cc06df28634627e487536b15548f2c5d54c68297f26f06447b SHA512 3e8f33de0f77d45af2ed82e8fd216d6fb4c3aa080648cf490bdaef233fac1c635e10660ac0bfcdf0a43af48d454e0d4d7c04cb650f5f89660e8e4efc10104f56
+DIST tracker-3.3.0.tar.xz 1969132 BLAKE2B a43183599ee3d3947450e4d58fd02094a41d5978d0c3be120b995844eca5ddc0f7e37bd98e886bec99d5c9342f5ba6f92eec2cd729a1793ce2141bfa5ff99908 SHA512 0a55a80b44c2267f149c4c83ecbe42ca27a0645bd4fc206984999520f6bed3b7c63c71f81450f40ce2896223ce17326add20e7f39a71c821d754f30b8ce157bc
diff --git a/app-misc/tracker/tracker-3.3.0.ebuild b/app-misc/tracker/tracker-3.3.0.ebuild
new file mode 100644
index 000000000000..8875b2911b7e
--- /dev/null
+++ b/app-misc/tracker/tracker-3.3.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+VALA_MIN_API_VERSION="0.40"
+
+inherit bash-completion-r1 flag-o-matic gnome.org gnome2-utils linux-info meson python-any-r1 systemd vala xdg
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tracker"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3/0" # libtracker-sparql-3.0 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +miners stemmer test"
+RESTRICT="!test? ( test )"
+
+PV_SERIES=$(ver_cut 1-2)
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=sys-apps/dbus-1.3.2
+ >=dev-libs/gobject-introspection-1.54:=
+ >=dev-libs/icu-4.8.1.2:=
+ >=dev-libs/json-glib-1.4
+ >=net-libs/libsoup-2.40.1:2.4
+ >=dev-libs/libxml2-2.7
+ >=dev-db/sqlite-3.29.0
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-text/asciidoc
+ dev-libs/libxslt
+ $(vala_depend)
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.8
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.5
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep 'dev-python/tappy[${PYTHON_USEDEP}]')
+ )
+ ${PYTHON_DEPS}
+"
+PDEPEND="miners? ( >=app-misc/tracker-miners-${PV_SERIES} )"
+
+function inotify_enabled() {
+ if linux_config_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
+}
+
+python_check_deps() {
+ use test || return 0
+ has_version -b "dev-python/tappy[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ inotify_enabled
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ vala_setup
+}
+
+src_configure() {
+ append-cflags -DTRACKER_DEBUG -DG_DISABLE_CAST_CHECKS
+
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dman=true
+ $(meson_feature stemmer)
+ -Dunicode_support=icu
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dsystemd_user_services_dir="$(systemd_get_userunitdir)"
+ $(meson_use test tests)
+ -Dintrospection=enabled
+ -Dsoup=soup2
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}