summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-01-29 11:42:35 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-01-29 11:42:35 -0800
commit06f06e7b9f8d243226d33325348414c710c11b94 (patch)
tree4f2d86bd3b51acd2e275e7c56c6ecb868324d32a /app-misc/tmuxp
parentdev-python/libtmux: Version bump to 0.10.3 (diff)
downloadgentoo-06f06e7b9f8d243226d33325348414c710c11b94.tar.gz
gentoo-06f06e7b9f8d243226d33325348414c710c11b94.tar.bz2
gentoo-06f06e7b9f8d243226d33325348414c710c11b94.zip
app-misc/tmuxp: Version bump to 1.9.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/files/tmuxp-1.9.4-relax-click-dep.patch13
-rw-r--r--app-misc/tmuxp/tmuxp-1.9.4.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 2b6b46c58fac..fccaf07461be 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -3,3 +3,4 @@ DIST tmuxp-1.6.5.tar.gz 1017117 BLAKE2B 4cc8955f9dcfffd237ffde3e7487496aaf85dd88
DIST tmuxp-1.7.2.tar.gz 1027293 BLAKE2B 2564d196c9c327584d24f57ce72165a7cdff2209fe6869a4d3519eb0246329cd8159ecaa20c2a39e153bde224201b1f846f4244c4df72ac540cf0d71f9fba75a SHA512 2ccf63c9f5b7049438ca6079894aac92a0f7496a56c68d88e5a9d5c2a42188a4e40d559792857881f492b28392a329697d4d43781f38ee7c49ed592aac8a69f8
DIST tmuxp-1.8.2.tar.gz 1019801 BLAKE2B 1e02139df6cc5ee0aec31e3a39413297195b6951a9acaa487a8f705f7f28b79ece0e5388284d017dbf45744540eecb0809e4a7e668f91b824aa0e4adcd64bcf8 SHA512 b6993be72bdab1ef469dbf43d056fbd812612437716af8a4c2e803a55f7ad803246789ccb0b3cafa5ad9047ae86426b4aede27480f20f6d3593d9bf737b74323
DIST tmuxp-1.9.2.tar.gz 816621 BLAKE2B f471ba2b7a6f97b123661ca2473c63273dc79b08cbe25f4ea756d174ab58e5070d0fc2dfbe8ec254785946e2fa139121d2e9fa5d7d5c127c18580e514064523d SHA512 e4af94fde475c999cee5aa6ad4b60a05c3a9f6f338290406043544250c4dcf688bc39e501631f442b59009156e04eb383098ea717fe7be8e9811b44886515935
+DIST tmuxp-1.9.4.tar.gz 821650 BLAKE2B 34454919e811bc4901dcb570046b45d481934ab36f9b8f50753972fe6545ca9e487b2f04ee818c4b54eea01181c62efb1f5262ab033f2fc92c3cee3828d16bf4 SHA512 ecf113011231a03998b3be2d146f7e6c6cc2ccfc36af59b88d51e09726259c92dc4360bde569fba13ca8d81eb9639f85b45cd5f4b50d70d347e3237e396ea446
diff --git a/app-misc/tmuxp/files/tmuxp-1.9.4-relax-click-dep.patch b/app-misc/tmuxp/files/tmuxp-1.9.4-relax-click-dep.patch
new file mode 100644
index 000000000000..a4450e37c11e
--- /dev/null
+++ b/app-misc/tmuxp/files/tmuxp-1.9.4-relax-click-dep.patch
@@ -0,0 +1,13 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 228a1ae..e24f106 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -49,7 +49,7 @@ tmuxp = 'tmuxp:cli.cli'
+
+ [tool.poetry.dependencies]
+ python = "^3.7"
+-click = ">7,<8.1"
++click = ">7.0"
+ kaptan = ">=0.5.10"
+ libtmux = "~0.10.3"
+ colorama = ">=0.3.9"
diff --git a/app-misc/tmuxp/tmuxp-1.9.4.ebuild b/app-misc/tmuxp/tmuxp-1.9.4.ebuild
new file mode 100644
index 000000000000..de2f17a48f41
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ >=dev-python/kaptan-0.5.10[${PYTHON_USEDEP}]
+ ~dev-python/libtmux-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tmuxp-1.6.4-tests.patch"
+ "${FILESDIR}/tmuxp-1.7.2-tests.patch"
+ "${FILESDIR}/tmuxp-1.9.4-relax-click-dep.patch"
+ "${FILESDIR}/tmuxp-1.9.2-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest
+}