summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-11-13 11:03:27 +0100
committerHans de Graaff <graaff@gentoo.org>2022-11-14 07:42:06 +0100
commit1069c86e5578828a2640f2cc3510fe11c0ba804b (patch)
tree0ca6885856dce8f63d91e62653ae4f756090590e /app-misc/sphinx
parentdev-python/libsass-python: Remove redundant MY_P (diff)
downloadgentoo-1069c86e5578828a2640f2cc3510fe11c0ba804b.tar.gz
gentoo-1069c86e5578828a2640f2cc3510fe11c0ba804b.tar.bz2
gentoo-1069c86e5578828a2640f2cc3510fe11c0ba804b.zip
app-misc/sphinx: lock C/C++ to older versions of the standard
This code is no longer maintained and has compatibility issues with newer C and C++ standards. Lock to older standards to avoid compilation issues. Closes: https://bugs.gentoo.org/880923 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/sphinx-2.2.11-r5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-misc/sphinx/sphinx-2.2.11-r5.ebuild b/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
index a12e8f50f0b2..462ddf809f44 100644
--- a/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
+++ b/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
#MY_P=${P/_/-}
MY_P=${P}-release
@@ -58,6 +58,10 @@ src_prepare() {
}
src_configure() {
+ # This code is no longer maintained and not compatible with modern C/C++ standards, bug #880923
+ append-cflags -std=gnu89
+ append-cxxflags -std=c++11
+
# fix libiconv detection
use !elibc_glibc && export ac_cv_search_iconv=-liconv