summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Barker <alex@1stleg.com>2020-04-17 09:40:28 -0700
committerLars Wendler <polynomial-c@gentoo.org>2020-12-14 18:17:30 +0100
commitef3bbfee73764fa2bbb48d87ad6d1fd6e8bafff1 (patch)
tree28202c7b93eaec1c0fe678f19aeebab07c373217 /app-misc/piper
parentdev-libs/libratbag: Bump to version 0.15 (diff)
downloadgentoo-ef3bbfee73764fa2bbb48d87ad6d1fd6e8bafff1.tar.gz
gentoo-ef3bbfee73764fa2bbb48d87ad6d1fd6e8bafff1.tar.bz2
gentoo-ef3bbfee73764fa2bbb48d87ad6d1fd6e8bafff1.zip
app-misc/piper-0.5.1: New support package
Bug: https://bugs.gentoo.org/629006 Closes: https://bugs.gentoo.org/629006 Signed-off-by: Alex Barker <alex@1stleg.com> Closes: https://github.com/gentoo/gentoo/pull/15323 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc/piper')
-rw-r--r--app-misc/piper/Manifest1
-rw-r--r--app-misc/piper/metadata.xml15
-rw-r--r--app-misc/piper/piper-0.5.1.ebuild52
3 files changed, 68 insertions, 0 deletions
diff --git a/app-misc/piper/Manifest b/app-misc/piper/Manifest
new file mode 100644
index 000000000000..9a1f22519818
--- /dev/null
+++ b/app-misc/piper/Manifest
@@ -0,0 +1 @@
+DIST piper-0.5.1.tar.gz 234944 BLAKE2B 1df33ca6e2d0dae95b34f8e3a98c6829a8f113ae68fb60980ff40374090b9272f86d69103c33fe0a4e1b0ac21a84724e7cabccca4ce8dd23d02f6d56e67d072b SHA512 13368521a9c32b2dc3300b129ed3bb07a6204623fa750f8f75ca31d2a3b60f43ae5f5066ef755814960d4890a489bdfd21b0e1b8f456b3445e0ba35ac06bc877
diff --git a/app-misc/piper/metadata.xml b/app-misc/piper/metadata.xml
new file mode 100644
index 000000000000..f8320608ec59
--- /dev/null
+++ b/app-misc/piper/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex@1stleg.com</email>
+ <name>Alex Barker</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">libratbag/piper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/piper/piper-0.5.1.ebuild b/app-misc/piper/piper-0.5.1.ebuild
new file mode 100644
index 000000000000..33eae628b921
--- /dev/null
+++ b/app-misc/piper/piper-0.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson python-single-r1 udev
+
+DESCRIPTION="GTK configuration application for libratbag"
+HOMEPAGE="https://github.com/libratbag/piper"
+SRC_URI="https://github.com/libratbag/piper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ >=dev-libs/libratbag-0.13
+ gnome-base/librsvg[introspection]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-evdev[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/libevdev
+ virtual/libudev
+"
+
+src_configure() {
+ python_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}