summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Barker <alex@1stleg.com>2021-08-08 12:24:47 -0700
committerIonen Wolkens <ionen@gentoo.org>2021-08-13 07:39:01 -0400
commit84aa44089077454a2550e03ab015fdac7eef3061 (patch)
tree0037a7ad9ff828ad6cf42ffde9e0cab717a5c86c /app-misc/piper
parentdev-db/postgresql: enable native spinlock support on riscv (diff)
downloadgentoo-84aa44089077454a2550e03ab015fdac7eef3061.tar.gz
gentoo-84aa44089077454a2550e03ab015fdac7eef3061.tar.bz2
gentoo-84aa44089077454a2550e03ab015fdac7eef3061.zip
app-misc/piper: Remove flake8 test
Closes: https://bugs.gentoo.org/807205 Signed-off-by: Alexander Barker <alex@1stleg.com> Closes: https://github.com/gentoo/gentoo/pull/21919 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-misc/piper')
-rw-r--r--app-misc/piper/files/piper-0.5.1-disable-flake8-linting.patch17
-rw-r--r--app-misc/piper/piper-0.5.1-r2.ebuild4
2 files changed, 21 insertions, 0 deletions
diff --git a/app-misc/piper/files/piper-0.5.1-disable-flake8-linting.patch b/app-misc/piper/files/piper-0.5.1-disable-flake8-linting.patch
new file mode 100644
index 000000000000..a0ede6671e04
--- /dev/null
+++ b/app-misc/piper/files/piper-0.5.1-disable-flake8-linting.patch
@@ -0,0 +1,17 @@
+Remove linting test that is broken upstream.
+Bug: https://bugs.gentoo.org/807205
+
+--- piper-0.5.1/meson.build
++++ piper-0.5.1/meson.build
+@@ -119,11 +119,3 @@
+ configuration: config_piper_devel)
+
+ meson.add_install_script('meson_install.sh')
+-
+-flake8 = find_program('flake8', required: false)
+-if flake8.found()
+- test('flake8', flake8,
+- args: ['--ignore=E501,W504',
+- join_paths(meson.source_root(), 'piper'),
+- join_paths(meson.source_root(), 'piper.in')])
+-endif
diff --git a/app-misc/piper/piper-0.5.1-r2.ebuild b/app-misc/piper/piper-0.5.1-r2.ebuild
index 029aadea4ce6..9379797c495b 100644
--- a/app-misc/piper/piper-0.5.1-r2.ebuild
+++ b/app-misc/piper/piper-0.5.1-r2.ebuild
@@ -40,6 +40,10 @@ DEPEND="
virtual/libudev
"
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-flake8-linting.patch
+)
+
src_configure() {
python_setup
meson_src_configure