summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-17 20:59:15 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-17 20:59:15 +0200
commit208d159b2644a1b73e4bcceebc4391ca932a095e (patch)
tree5a0e51aab1a081831a1beab4967d0edf68225b41 /app-misc/mkcert/mkcert-1.4.0.ebuild
parentapp-admin/helm: Remove old (diff)
downloadgentoo-208d159b2644a1b73e4bcceebc4391ca932a095e.tar.gz
gentoo-208d159b2644a1b73e4bcceebc4391ca932a095e.tar.bz2
gentoo-208d159b2644a1b73e4bcceebc4391ca932a095e.zip
app-misc/mkcert: Version bump to 1.4.0
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-misc/mkcert/mkcert-1.4.0.ebuild')
-rw-r--r--app-misc/mkcert/mkcert-1.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/mkcert/mkcert-1.4.0.ebuild b/app-misc/mkcert/mkcert-1.4.0.ebuild
new file mode 100644
index 000000000000..834a1dd46f17
--- /dev/null
+++ b/app-misc/mkcert/mkcert-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/FiloSottile/mkcert"
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A zero-config tool to make locally trusted development certificates"
+HOMEPAGE="https://github.com/FiloSottile/mkcert"
+SRC_URI="https://github.com/FiloSottile/mkcert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go install -v ${EGO_PN} || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/mkcert
+ dodoc src/${EGO_PN}/README.md
+}