summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/figlet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/figlet')
-rw-r--r--app-misc/figlet/Manifest1
-rw-r--r--app-misc/figlet/figlet-2.2.5.ebuild40
-rw-r--r--app-misc/figlet/files/figlet.bashcomp52
-rw-r--r--app-misc/figlet/metadata.xml8
4 files changed, 101 insertions, 0 deletions
diff --git a/app-misc/figlet/Manifest b/app-misc/figlet/Manifest
new file mode 100644
index 000000000000..b7875db3adf8
--- /dev/null
+++ b/app-misc/figlet/Manifest
@@ -0,0 +1 @@
+DIST figlet-2.2.5.tar.gz 233201 SHA256 bf88c40fd0f077dab2712f54f8d39ac952e4e9f2e1882f1195be9e5e4257417d SHA512 bb9610fd89a51dd3e65c485653fe1292f47dbca7cb9a05af4ce317f5d776bb346ae455aec07fc37c290f6658639920fd7c431c1135a0f4d456a21c0bd25f99fb WHIRLPOOL bc5408f6e530adc099c1ef1798b5bbdf992f8614ba6e8b14d7cbc2c42232e62c9fa54e47fb8a2991e5e86b3fba4d43f1f9356c5dee77ff07d89dfbc16b60bdd8
diff --git a/app-misc/figlet/figlet-2.2.5.ebuild b/app-misc/figlet/figlet-2.2.5.ebuild
new file mode 100644
index 000000000000..e94e350280ba
--- /dev/null
+++ b/app-misc/figlet/figlet-2.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="program for making large letters out of ordinary text"
+HOMEPAGE="http://www.figlet.org/"
+SRC_URI="ftp://ftp.figlet.org/pub/figlet/program/unix/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+src_compile() {
+ emake clean
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ all
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ MANDIR="${EPREFIX}/usr/share/man" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ doman chkfont.6 figlet.6 figlist.6 showfigfonts.6
+ dodoc README figfont.txt
+
+ dobashcomp "${FILESDIR}"/figlet.bashcomp
+}
diff --git a/app-misc/figlet/files/figlet.bashcomp b/app-misc/figlet/files/figlet.bashcomp
new file mode 100644
index 000000000000..6a64da3f3660
--- /dev/null
+++ b/app-misc/figlet/files/figlet.bashcomp
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# bash command-line completion for figlet
+# author: Aaron Walker <ka0ttic@gentoo.org>
+
+_figlet() {
+ local cur prev opts x
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-f -d -c -l -r -x -t -w -p -n -D -E -C -N -s -S -k -W -o \
+ -m -v -I -L -R -X"
+
+ if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=( $(compgen -W "${opts}" -- $cur) )
+ return 0
+ fi
+
+ case "${prev}" in
+ -f)
+ COMPREPLY=( $(compgen -f -- $cur) \
+ $(compgen -W "$(\
+ for x in /usr/share/figlet/*.flf ; do \
+ [[ -f ${x} ]] && { local y=${x##*/} ; echo ${y%.*} ; } \
+ done)" -- $cur) )
+ ;;
+ -d)
+ COMPREPLY=( $(compgen -d -S '/' -- $cur) )
+ ;;
+ -C)
+ COMPREPLY=( $(compgen -f -- $cur) \
+ $(compgen -W "$(\
+ for x in /usr/share/figlet/*.flc ; do \
+ [[ -f ${x} ]] && { local y=${x##*/} ; echo ${y%.*} ; } \
+ done)" -- $cur) )
+ ;;
+ -m)
+ COMPREPLY=( $(compgen -W "$(\
+ for ((x = 1 ; x < 64 ; x++)) ; do \
+ echo ${x} ; \
+ done)" ) )
+ ;;
+ -I)
+ COMPREPLY=( $(compgen -W "-1 0 1 2 3 4" -- $cur) )
+ ;;
+ esac
+}
+complete -o filenames -F _figlet figlet
+
+# vim: set ft=sh tw=80 sw=4 et :
diff --git a/app-misc/figlet/metadata.xml b/app-misc/figlet/metadata.xml
new file mode 100644
index 000000000000..2c7916afbb38
--- /dev/null
+++ b/app-misc/figlet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>mr_bones_@gentoo.org</email>
+<name>Michael Sterrett</name>
+</maintainer>
+</pkgmetadata>