summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-06-15 12:46:51 +0000
committerThomas Deutschmann <whissi@gentoo.org>2021-06-16 11:50:50 +0200
commit8d203193832f2c8a1d1df340f4cfd4a35d2e8d1d (patch)
treeb61be9e582252a49ad5337d0bfa724f40f00e92a /app-misc/elasticsearch
parentnet-irc/hexchat: Removed old (diff)
downloadgentoo-8d203193832f2c8a1d1df340f4cfd4a35d2e8d1d.tar.gz
gentoo-8d203193832f2c8a1d1df340f4cfd4a35d2e8d1d.tar.bz2
gentoo-8d203193832f2c8a1d1df340f4cfd4a35d2e8d1d.zip
app-misc/elasticsearch: bump to 6.8.16
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-misc/elasticsearch')
-rw-r--r--app-misc/elasticsearch/Manifest2
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.8.16.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 261504866e1e..1b40187d9aca 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,4 +1,6 @@
DIST elasticsearch-6.8.15.tar.gz 149102328 BLAKE2B 0ce9ba565d751cd27721f3d49dd24761937c3476cee4896ba1a4d84e4fc238296129481f18cad64270fe8af71a043c2e8e583df14f2a084850fb10c93fcea0ef SHA512 c62c4d9d1bb83e10d3e1079f56b834f2f89b1f712c29d9ce7e81786199c71d287ecbf6df158eca56a7af711eafe13dfb276e12b34e1a0a6cf6719e1fbb44a142
+DIST elasticsearch-6.8.16.tar.gz 149125098 BLAKE2B cafdb7fd97b3df087472c65ede9eb9c703f6499a03d70c5fcc497bdaafc0757d0b9e7fe84d0a8c710cdecbe85654fdad1f854209015a545e0bf43d8e585a481f SHA512 0b15f77ba5962970ef38869a233ee3d091a64b218cf42dc5f4bdd8a81322739992f75e3c438295435f28af20af1e138c2f5e3afed76a7ebc0f348764528dd0f3
DIST elasticsearch-7.12.0-no-jdk-linux-x86_64.tar.gz 173069694 BLAKE2B 5de74b1e6de743246cf48e32254f9646fa25c2820d0be9df886fdefe131a302ddb8906546147f0d284e2fc0faf8cc0238bf854fe1611d28bf1e7cb1518bd4e31 SHA512 205aa2a2fa2ab7eb7b54087420e0123aa97e5456e2e1f31cad9ea7b84be3f9823a2a7c47d4cf1697833e5f795359477d3a3b0ea4955a8f92583cf2228071827e
DIST elasticsearch-7.12.1-no-jdk-linux-x86_64.tar.gz 173079845 BLAKE2B 98214508c2c1dcb631f59d9e51d5949f9a7c5d1f68ff78c8d93af04c6a21fa1e1c6e2051f04bbdb8154443d6295ad54af2016695fcb9193b7595e1486777ba98 SHA512 c91fd66668977280d7339caf6b4fef9fce5640492f0e2a65bc537c6da8397c801a3727f1ff56b7a1591b11ea47195720c588a4eba473043f829a87cd3dcc0af4
DIST elasticsearch-oss-6.8.15.tar.gz 68240776 BLAKE2B 431d845e02f2118a98021af4422ece34274b6d0811a32c5a3e679da3f8f56ca9cd45949307268811edbb83327a4a80fb84866cbbaaf01f7d3af042412b1e1bfa SHA512 7e6a819339ac6043af218f9d97d5d68c50ac46900e4293e7fa18992f7a50b10b0ab2434e26ff0dc1546204ae7526de8ac6ef6545fc0db9c862ceeaa0d96c56f5
+DIST elasticsearch-oss-6.8.16.tar.gz 68248767 BLAKE2B 2c8c14a6e2f837bc547de2e8c97f2fbe2dbf7743978a00e2fc37cd61eb46144df2a24f67360761e0342987b9194176109cfbd07545d2e8f88cae48f9508c659c SHA512 0f46c69136312d535ccff4663655500538ffc924bbe50350c2eed3372609a28e642bb906cbb9a631af5fa10568a16c1a630ef181c383ee247c98325ddc85e04c
diff --git a/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild b/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild
new file mode 100644
index 000000000000..6b347e7957c4
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz )
+ !x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${PN}-oss-${PV}.tar.gz )"
+LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain x-pack? ( Elastic )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="x-pack"
+
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ virtual/jre:1.8"
+
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+src_prepare() {
+ default
+
+ rm bin/*.{bat,exe} LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+
+ if use x-pack; then
+ rm bin/x-pack/*.bat || die
+ rm -r modules/x-pack-ml/platform/{darwin,windows}-x86_64 || die
+ fi
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ chmod +x "${ED}"/usr/share/${PN}/bin/* || die
+
+ if use x-pack; then
+ chmod +x "${ED}"/usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin/* || die
+ fi
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.3" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.6" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}