summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 19:41:33 +0100
committerSam James <sam@gentoo.org>2022-04-17 19:59:17 +0100
commit1985c105eb92414994aeea8a5d31818f19c33528 (patch)
tree0fb75453377f3ecc272807906e0e01f38d6d556b /app-misc/digitemp
parentapp-misc/ddccontrol-db: drop 20190826_p20200613 (diff)
downloadgentoo-1985c105eb92414994aeea8a5d31818f19c33528.tar.gz
gentoo-1985c105eb92414994aeea8a5d31818f19c33528.tar.bz2
gentoo-1985c105eb92414994aeea8a5d31818f19c33528.zip
app-misc/digitemp: drop 3.7.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest1
-rw-r--r--app-misc/digitemp/digitemp-3.7.1.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index c8bc36ce59fe..dd2dbeda2fb8 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,2 +1 @@
-DIST digitemp-3.7.1.tar.gz 144870 BLAKE2B 5d00197ba0122772d96c3185f430119961d214f50dc07dcd5881e1aa1135283680ff38b4d92736827f5c7644b11930b9418b8467f276e832e40f4228d08d1774 SHA512 e5eaf576b544c61049a358dece7dc96d9793b751ef08645060f3b2c1a2006e2906c3aa3f97de3dab46818290d664d2e784a948b2495b538a200b6d71b03173d2
DIST digitemp-3.7.2.tar.gz 146166 BLAKE2B 9718e5d8a135e99cfd8893f5f4d2cc40a0bcdffa4e01c4ef460d654b38d9808c75ea1efced6211672033a67be8ba7f30f34320ef8e64d47d8a88be8bbac8c997 SHA512 807934ecc743df5ee69e9a8a0f5e90e469f03e577cc80b4510e6ac4ecc61ff9c79e05642602a4f50b4acda7e1f53e33016e6c201898ab0b44c76f3f7ac028820
diff --git a/app-misc/digitemp/digitemp-3.7.1.ebuild b/app-misc/digitemp/digitemp-3.7.1.ebuild
deleted file mode 100644
index 65431c4aae4f..000000000000
--- a/app-misc/digitemp/digitemp-3.7.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire protocol"
-HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
-SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-IUSE="ds9097 ds9097u ds2490"
-
-DEPEND="ds2490? ( virtual/libusb:0 )"
-
-targets() {
- # default is to compile to the ds9097u.
- if ! ( use ds9097 || use ds9097u || use ds2490 ); then
- echo ds9097u
- fi
-
- for target in ds9097 ds9097u ds2490; do
- if use ${target}; then
- echo ${target}
- fi
- done
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
- -e "/^LIBS/s:=:= ${LDFLAGS}:" \
- Makefile || die
-
- # default is to compile to the ds9097u.
- if ! ( use ds9097 || use ds9097u || use ds2490 ); then
- ewarn "If you don't choose a component to install, we default to ds9097u"
- fi
-}
-
-src_compile() {
- local targets=$(targets)
-
- for target in ${targets}; do
- emake clean
- emake CC="$(tc-getCC)" LOCK="no" ${target}
- done
-}
-
-src_install() {
- for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
- dobin digitemp_${target} && \
- dosym digitemp_${target} /usr/bin/digitemp
- done
-
- if [[ $(targets|wc -l) -ge 1 ]]; then
- ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
- ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
- fi
-
- dodoc README FAQ TODO
-
- for example in perl python rrdb; do
- docinto ${example}_examples
- dodoc -r ${example}/*
- done
-}
-
-pkg_postinst() {
- elog "Examples of using digitemp with python, perl, and rrdtool are"
- elog "located in /usr/share/doc/${PF}/"
-}