summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-02-28 20:52:05 +0100
committerSam James <sam@gentoo.org>2024-02-28 20:41:33 +0000
commit1916f9cc0cf325911b783e970f13c30469ef6ce2 (patch)
tree1895429b55a4eb255b98c9e345c76d0bd3c1537c /app-misc/binwalk
parentllvm.org.eclass: Remove old snapshot support (diff)
downloadgentoo-1916f9cc0cf325911b783e970f13c30469ef6ce2.tar.gz
gentoo-1916f9cc0cf325911b783e970f13c30469ef6ce2.tar.bz2
gentoo-1916f9cc0cf325911b783e970f13c30469ef6ce2.zip
app-misc/binwalk: verbump to 2.3.6, update live ebuild
Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/binwalk')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.3.6.ebuild37
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild17
3 files changed, 43 insertions, 12 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index bc1bd0f85a9d..fdee3584aa95 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1 +1,2 @@
DIST binwalk-2.3.4.tar.gz 39723471 BLAKE2B a5eac4242402c5034c293432131950bed9aff762c5db86b200a1f555bdfeeb1c6fda225393149f7beca2923141f2ae7930738038f2d039513cb06dfae9601b81 SHA512 5a5e16035dfc05b94ae4ee3969a337336c550606b71e20fcb1f150c4b38ef2084b6a823ce2a8050f4b41616b7d7c31cfb04bf43e7f2c977ab1a634aba9d67fec
+DIST binwalk-2.3.6.tar.gz 39723335 BLAKE2B 20710dc32f67981b1ba69ced649bfddc0247b9054a30ba9a8ab17710094fa4f45a44b32b18e2de6e0c63d632044432e8d4a8ec8cdacb007996b7d91b983547bc SHA512 05e06682a9b8aa6b68b580b6818a2f08d8d81d89961f6cacfd9d14185c26727bbdf6dedb2f26079fffebf7de6f45002944ed8f3475ba04e4b05ac6d5c19560ea
diff --git a/app-misc/binwalk/binwalk-2.3.6.ebuild b/app-misc/binwalk/binwalk-2.3.6.ebuild
new file mode 100644
index 000000000000..3faee6d44b5c
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.3.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/OSPG/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/OSPG/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index b21509dda458..3faee6d44b5c 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
inherit distutils-r1
if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
+ EGIT_REPO_URI="https://github.com/OSPG/binwalk.git"
inherit git-r3
else
- SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/OSPG/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
fi
@@ -22,14 +22,7 @@ HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
LICENSE="MIT"
SLOT="0"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch
- "${FILESDIR}"/2.3.3-tests.patch
- "${FILESDIR}"/${PN}-2.3.3-syntax-fix.patch
-
-)
-
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_install_all() {
local DOCS=( API.md INSTALL.md README.md )