summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-11-23 22:05:57 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-11-23 22:11:30 -0500
commit2517c840b2ec40bdfa1b6575fd7cf84a2cd9904f (patch)
tree4434900091058dd3632669c4409089028c957c9f /app-laptop
parentdev-python/icalendar: Stabilize 6.0.1 amd64, #943616 (diff)
downloadgentoo-2517c840b2ec40bdfa1b6575fd7cf84a2cd9904f.tar.gz
gentoo-2517c840b2ec40bdfa1b6575fd7cf84a2cd9904f.tar.bz2
gentoo-2517c840b2ec40bdfa1b6575fd7cf84a2cd9904f.zip
app-laptop/hdapsd: trivial patch to fix the build with gcc-15
I'm doing this one straight to stable because, ultimately, the stabilization process is that I say to stabilize it. So long as it builds, this package requires special hardware to actually test, and it's hardware that hasn't been made for a looooong time. Closes: https://bugs.gentoo.org/944301 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/hdapsd/files/hdapsd-20141203-usage-doesnt-take-args.patch23
-rw-r--r--app-laptop/hdapsd/hdapsd-20141203-r3.ebuild5
2 files changed, 26 insertions, 2 deletions
diff --git a/app-laptop/hdapsd/files/hdapsd-20141203-usage-doesnt-take-args.patch b/app-laptop/hdapsd/files/hdapsd-20141203-usage-doesnt-take-args.patch
new file mode 100644
index 000000000000..4723aeb543d6
--- /dev/null
+++ b/app-laptop/hdapsd/files/hdapsd-20141203-usage-doesnt-take-args.patch
@@ -0,0 +1,23 @@
+From f74b32c417af940dc1ebb64cde49503253064c28 Mon Sep 17 00:00:00 2001
+From: Evgeni Golov <evgeni@golov.de>
+Date: Thu, 30 May 2024 17:32:56 +0200
+Subject: [PATCH] don't pass argv to usage, it doesn't take any params
+
+thanks clang!
+---
+ src/hdapsd.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/hdapsd.c b/src/hdapsd.c
+index 03d21a1..92c6f25 100644
+--- a/src/hdapsd.c
++++ b/src/hdapsd.c
+@@ -1027,7 +1027,7 @@ int main (int argc, char** argv)
+ }
+
+ if (disklist == NULL)
+- usage(argv);
++ usage();
+
+ /* Let's see if we're on a ThinkPad or on an *Book */
+ if (!position_interface)
diff --git a/app-laptop/hdapsd/hdapsd-20141203-r3.ebuild b/app-laptop/hdapsd/hdapsd-20141203-r3.ebuild
index dc97598dd6d8..e887d92dc008 100644
--- a/app-laptop/hdapsd/hdapsd-20141203-r3.ebuild
+++ b/app-laptop/hdapsd/hdapsd-20141203-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,10 +13,11 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="libconfig"
-BDEPEND=""
DEPEND="libconfig? ( dev-libs/libconfig:= )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-usage-doesnt-take-args.patch" )
+
pkg_setup() {
# We require the hdaps module which can either come from either the
# kernel itself (CONFIG_SENSORS_HDAPS) or from the tp_smapi package.