summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-08-01 00:51:48 +0200
committerDavid Seifert <soap@gentoo.org>2022-08-01 00:51:48 +0200
commitfb26f1a928bc51e8d7f133cb9c818a9468ac071f (patch)
treec78b2783131f8bc5caef4ac7a299fa679167e8c3 /app-laptop/tpacpi-bat/tpacpi-bat-3.1-r1.ebuild
parentapp-laptop/tpacpi-bat: drop 3.0-r1 (diff)
downloadgentoo-fb26f1a928bc51e8d7f133cb9c818a9468ac071f.tar.gz
gentoo-fb26f1a928bc51e8d7f133cb9c818a9468ac071f.tar.bz2
gentoo-fb26f1a928bc51e8d7f133cb9c818a9468ac071f.zip
app-laptop/tpacpi-bat: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-laptop/tpacpi-bat/tpacpi-bat-3.1-r1.ebuild')
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-3.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-3.1-r1.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-3.1-r1.ebuild
new file mode 100644
index 000000000000..74b72ce18688
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-3.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/teleshoes/tpacpi-bat.git"
+else
+ SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dobin tpacpi-bat
+ dodoc README.md battery_asl
+
+ newinitd "${FILESDIR}"/${PN}.initd.2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.1 ${PN}
+ systemd_newunit examples/systemd_fixed_threshold/tpacpi.service \
+ ${PN}.service
+}