summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-01-05 12:30:08 +0800
committerYixun Lan <dlan@gentoo.org>2024-01-11 00:20:08 +0000
commite9f9c8fcff4eec0a20eb1925f55869cd0f7839ac (patch)
treee3372bf23be776b25fb027f88675afdf90889abd /app-i18n
parentapp-i18n/fcitx-configtool: add 5.1.3 (diff)
downloadgentoo-e9f9c8fcff4eec0a20eb1925f55869cd0f7839ac.tar.gz
gentoo-e9f9c8fcff4eec0a20eb1925f55869cd0f7839ac.tar.bz2
gentoo-e9f9c8fcff4eec0a20eb1925f55869cd0f7839ac.zip
app-i18n/fcitx-lua: add 5.0.12
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-lua/Manifest1
-rw-r--r--app-i18n/fcitx-lua/fcitx-lua-5.0.12.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-i18n/fcitx-lua/Manifest b/app-i18n/fcitx-lua/Manifest
index 8fefb82b8810..8c2b5cc65d6d 100644
--- a/app-i18n/fcitx-lua/Manifest
+++ b/app-i18n/fcitx-lua/Manifest
@@ -1 +1,2 @@
DIST fcitx-lua-5.0.11.tar.xz 34320 BLAKE2B 9140e96362d8a294149028946c3072c195145ccdf4f350d438904305dcca3fb4b3c70f205bd2ff83f700ae8822b2bd99efc5ec77009f5636c72d7ea10d6d15f4 SHA512 c69391efb910cc476608022d15d6e06323bef6cf50c9c63297827969a796b153ad82c7953c3a8fc4432bb887323aa15456d4a8fc246814e165efa54307fa7efe
+DIST fcitx-lua-5.0.12.tar.xz 33576 BLAKE2B 2aa2d526e42270a14efc3f163baf775012afb917bdb4aa7f52b2bf420265095100dfc84b61c34e892403b89bc96f3e258fa8030a735f234b820644bb8e443122 SHA512 1f6273ff8b9c0c3ef12dfcf508535b7865b33b102a8e158e82853c25717351339ba055012288d857f0aea5596398dd65ab9ed0c822a533b715dafcea3ec44798
diff --git a/app-i18n/fcitx-lua/fcitx-lua-5.0.12.ebuild b/app-i18n/fcitx-lua/fcitx-lua-5.0.12.ebuild
new file mode 100644
index 000000000000..e0a59277feee
--- /dev/null
+++ b/app-i18n/fcitx-lua/fcitx-lua-5.0.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+MY_PN="fcitx5-lua"
+
+inherit cmake lua-single xdg
+
+DESCRIPTION="Lua support for fcitx"
+HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="+dlopen test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-i18n/fcitx:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DLOPEN=$(usex dlopen)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}