summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-09-08 22:16:34 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-09-08 22:16:34 +0900
commit62c4cace3195b2a1b7303958365641bede1ec0ea (patch)
tree58e3c1db6f2c99dca16b5dfcee2b7ed7e147b494 /app-i18n
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-62c4cace3195b2a1b7303958365641bede1ec0ea.tar.gz
gentoo-62c4cace3195b2a1b7303958365641bede1ec0ea.tar.bz2
gentoo-62c4cace3195b2a1b7303958365641bede1ec0ea.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.18.10.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index a1844a6b4ff7..f12ade14f89f 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1 +1,2 @@
+DIST ibus-typing-booster-2.18.10.tar.gz 11086667 BLAKE2B 23c8958a3b1e0c7995f1c3ce3b0b3601e6f1ef12650739af861d011004e4eaf7d6bf6f61fb8d7797ef2f46c557248a909ede93e423ba28f8ad1c76d6ed937085 SHA512 a0eddaef7cbc44b570cc9bd0a606efe3902468eca6cbe7ab1b0d6cb70d917d3c48c9783963b4e7dd4ede358d969623aea292917e76d7f8ab7b0a3a95a8565c3c
DIST ibus-typing-booster-2.18.9.tar.gz 11060426 BLAKE2B 5a2e302bb93002c68e5a61001e013a26043e0b20922b6e79bfc96ebb0b4dbdd920df96d13545619e0b50684c7bf678b1c3df2556a40b0d4660439fc6984acd80 SHA512 1fe9dd28a042be7d946dc0a800363cd7870e8357fa75e4f57acd201b3cca96cfaab4ffbff1a53146713204e8c246ab1cf33ea379e9e1a3aa9b848306567cb7b3
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.18.10.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.18.10.ebuild
new file mode 100644
index 000000000000..58166b805e3c
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.18.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}