summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-03 17:42:29 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-04 16:01:42 +0200
commitf1dccfb731617fdbcf810a7c34b47db078646cda (patch)
treeb92e7592b9a34d4c9e07a601f9ae98dd898dd8d8 /app-i18n/poedit
parentapp-emulation/wine-vanilla: Update from l10n.eclass to plocale.eclass (diff)
downloadgentoo-f1dccfb731617fdbcf810a7c34b47db078646cda.tar.gz
gentoo-f1dccfb731617fdbcf810a7c34b47db078646cda.tar.bz2
gentoo-f1dccfb731617fdbcf810a7c34b47db078646cda.zip
app-i18n/poedit: Update from l10n.eclass to plocale.eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-i18n/poedit')
-rw-r--r--app-i18n/poedit/poedit-2.2.4.ebuild8
-rw-r--r--app-i18n/poedit/poedit-2.3.1.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/app-i18n/poedit/poedit-2.2.4.ebuild b/app-i18n/poedit/poedit-2.2.4.ebuild
index 371ec5eb7eba..649171e8a417 100644
--- a/app-i18n/poedit/poedit-2.2.4.ebuild
+++ b/app-i18n/poedit/poedit-2.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PLOCALES="af an ar az be be@latin bg bs ca ckb co cs da de el en_GB es et eu fa fi fr ga gl he hr hu hy id is it ja ka kab kk ko lt lv ms nb nl oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv tg th tr uk uz vi zh_CN zh_TW"
WX_GTK_VER=3.0-gtk3
-inherit gnome2-utils l10n wxwidgets xdg
+inherit gnome2-utils plocale wxwidgets xdg
DESCRIPTION="GUI gettext translations editor"
HOMEPAGE="https://poedit.net"
@@ -36,8 +36,8 @@ src_prepare() {
rm "locales/${1}.mo" || die
}
- l10n_find_plocales_changes 'locales' '' '.mo'
- l10n_for_each_disabled_locale_do my_rm_loc
+ plocale_find_changes 'locales' '' '.mo'
+ plocale_for_each_disabled_locale my_rm_loc
setup-wxwidgets
xdg_src_prepare
diff --git a/app-i18n/poedit/poedit-2.3.1.ebuild b/app-i18n/poedit/poedit-2.3.1.ebuild
index 8297cef3d06c..0d73c514986b 100644
--- a/app-i18n/poedit/poedit-2.3.1.ebuild
+++ b/app-i18n/poedit/poedit-2.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PLOCALES="af an ar az be be@latin bg bs ca ckb co cs da de el en_GB es et eu fa fi fr ga gl he hr hu hy id is it ja ka kab kk ko lt lv ms nb nl oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv tg th tr uk uz vi zh_CN zh_TW"
WX_GTK_VER=3.0-gtk3
-inherit gnome2-utils l10n wxwidgets xdg
+inherit gnome2-utils plocale wxwidgets xdg
DESCRIPTION="GUI gettext translations editor"
HOMEPAGE="https://poedit.net"
@@ -36,8 +36,8 @@ src_prepare() {
rm "locales/${1}.mo" || die
}
- l10n_find_plocales_changes 'locales' '' '.mo'
- l10n_for_each_disabled_locale_do my_rm_loc
+ plocale_find_changes 'locales' '' '.mo'
+ plocale_for_each_disabled_locale my_rm_loc
setup-wxwidgets
xdg_src_prepare