summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/libguess
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/libguess')
-rw-r--r--app-i18n/libguess/Manifest2
-rw-r--r--app-i18n/libguess/libguess-1.1.ebuild35
-rw-r--r--app-i18n/libguess/libguess-1.2.ebuild35
-rw-r--r--app-i18n/libguess/metadata.xml8
4 files changed, 80 insertions, 0 deletions
diff --git a/app-i18n/libguess/Manifest b/app-i18n/libguess/Manifest
new file mode 100644
index 000000000000..c63be4fc037c
--- /dev/null
+++ b/app-i18n/libguess/Manifest
@@ -0,0 +1,2 @@
+DIST libguess-1.1.tar.bz2 79915 SHA256 733e4782817666f108d6e8fd5c117e36a006779e049866b6814a8bce9b4d5af7 SHA512 8f817da7f05ff53886395183134d3dae40b2d31bf2296f1614c08d87d68b389e18dbaf9327d9c31cf5d4fff04a89edc6af2476d3a92384c57d6d2b0147525084 WHIRLPOOL 3c2a00e8512aade473252b5a918d74e88213bfc2ff120944a306ca4cdb2b9d4af074eadfb584f82cbb41b75a7d98f1ab24468759573265b8d2f4a5e84238da69
+DIST libguess-1.2.tar.bz2 79685 SHA256 8019a16bdc7ca9d2efbdcc1429d48d033d5053d42e45fccea10abf98074f05f8 SHA512 a17269e42e12b81e0201a27e41d9e290ac7351000473ddfcb968d5fc6e09cb5753d0534277ec257d43224cb675c8d563849853ab68ab6079a35480d6c40fb053 WHIRLPOOL 13214225ce44ec8f5f717eef3dbf402a5522a4de835bffd3d12607c16f2187d14bf0f7e6cea0e94d7a4c7142422170085a268ad30538b50186e278d11264fb6a
diff --git a/app-i18n/libguess/libguess-1.1.ebuild b/app-i18n/libguess/libguess-1.1.ebuild
new file mode 100644
index 000000000000..3be3a3f4f8c8
--- /dev/null
+++ b/app-i18n/libguess/libguess-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="A high-speed character set detection library"
+HOMEPAGE="http://www.atheme.org/project/libguess"
+SRC_URI="http://distfiles.atheme.org/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-libs/libmowgli-0.7.0:0"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable examples) \
+ || die "econf failed"
+}
+
+src_test() {
+ cd src/tests
+ make || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}
diff --git a/app-i18n/libguess/libguess-1.2.ebuild b/app-i18n/libguess/libguess-1.2.ebuild
new file mode 100644
index 000000000000..4d1c2337d4d7
--- /dev/null
+++ b/app-i18n/libguess/libguess-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A high-speed character set detection library"
+HOMEPAGE="http://www.atheme.org/project/libguess"
+SRC_URI="http://rabbit.dereferenced.org/~nenolod/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-libs/libmowgli-0.7.0:0"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable examples) \
+ || die "econf failed"
+}
+
+src_test() {
+ cd src/tests
+ make || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}
diff --git a/app-i18n/libguess/metadata.xml b/app-i18n/libguess/metadata.xml
new file mode 100644
index 000000000000..7803cdb58252
--- /dev/null
+++ b/app-i18n/libguess/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>