summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-08-31 18:03:04 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-08-31 18:03:04 +0900
commit0141970ab1830ea738876620d1b9dc86692c457e (patch)
treec2ea821386e8b51b3592b3232efd137727349799 /app-i18n/ibus-table
parentdev-util/stripe-mock: Stabilize 0.188.0 x86, #938811 (diff)
downloadgentoo-0141970ab1830ea738876620d1b9dc86692c457e.tar.gz
gentoo-0141970ab1830ea738876620d1b9dc86692c457e.tar.bz2
gentoo-0141970ab1830ea738876620d1b9dc86692c457e.zip
app-i18n/ibus-table: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.17.7.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 4cbe756b08ea..84b58381b037 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
DIST ibus-table-1.17.6.tar.gz 1563218 BLAKE2B 45ad1f8f489f8df0ca1108df9fda910d0f144c10cff29d047f0e345efd1be9e5a6d6cd2b47ba59904769ba3f0c207d2d641c9e7299b0d1ca4b77ff59bffb5d4c SHA512 0c3f23595bf1ecc2c3e34962fca3e2317771ba0837c1a04fbcbaae089196994764307184dd482f0a9efcae2106e013ca51cf9530bd1c7cfb29070f54b16a276e
+DIST ibus-table-1.17.7.tar.gz 1564577 BLAKE2B 2052c082a11b87f46351bccedbb4b3dd896337af8b772a33a822a285a7685cfb68cbe3269f21790aefd3c151aa7390a095c51343ec7c461a2d15a3457abaf2d6 SHA512 938b589b16728f2a5bdfa64e06277cd2fd41719fa5033c3935a07a8350be746a75bf10702f0a17bcec2f9af591d2ccfe486486b788035c5c39cb62ca6f0cec74
diff --git a/app-i18n/ibus-table/ibus-table-1.17.7.ebuild b/app-i18n/ibus-table/ibus-table-1.17.7.ebuild
new file mode 100644
index 000000000000..4ecd082cf0d0
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.17.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}