summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-11-15 19:15:05 +0100
committerMike Gilbert <floppym@gentoo.org>2017-11-15 14:26:13 -0500
commita1524c065dff9dd8ac65b3c1ca19c0c0b1ff44f6 (patch)
tree22d7c8e954d8ab7422a90fa54b3c583fb0a64ca0 /app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild
parentprofiles/arch/powerpc/ppc32/package.use.mask: Mask macro-editor USE flag for ... (diff)
downloadgentoo-a1524c065dff9dd8ac65b3c1ca19c0c0b1ff44f6.tar.gz
gentoo-a1524c065dff9dd8ac65b3c1ca19c0c0b1ff44f6.tar.bz2
gentoo-a1524c065dff9dd8ac65b3c1ca19c0c0b1ff44f6.zip
app-i18n/fcitx-unikey: Version bump (0.2.7).
Diffstat (limited to 'app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild')
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild
new file mode 100644
index 000000000000..d76ff3bcecd8
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-unikey"
+fi
+
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-unikey"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+macro-editor"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libintl
+ macro-editor? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtgui-5.7:5
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex macro-editor)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}