summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-27 00:16:05 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:56:59 -0400
commitbbd8562b4806125dfcb7552a582e938167dcef93 (patch)
tree8583ca2ea2bda6282ad21255d64f7d87b04d2e5e /app-i18n/fcitx-libpinyin
parentapp-i18n/fcitx-libpinyin: Rename "dictmanager" USE flag to "dictionary-manager". (diff)
downloadgentoo-bbd8562b4806125dfcb7552a582e938167dcef93.tar.gz
gentoo-bbd8562b4806125dfcb7552a582e938167dcef93.tar.bz2
gentoo-bbd8562b4806125dfcb7552a582e938167dcef93.zip
app-i18n/fcitx-libpinyin: Version bump (0.5.3).
Diffstat (limited to 'app-i18n/fcitx-libpinyin')
-rw-r--r--app-i18n/fcitx-libpinyin/Manifest1
-rw-r--r--app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-i18n/fcitx-libpinyin/Manifest b/app-i18n/fcitx-libpinyin/Manifest
index bb9e3a40cd2f..c83d8477ceba 100644
--- a/app-i18n/fcitx-libpinyin/Manifest
+++ b/app-i18n/fcitx-libpinyin/Manifest
@@ -4,3 +4,4 @@ DIST fcitx-libpinyin-0.3.1_dict.tar.xz 15143832 SHA256 0b553c90d37c36e82ad692803
DIST fcitx-libpinyin-0.3.3_dict.tar.xz 15145448 SHA256 cac02fb2ac19d9072d58e2d9383297e21942caf71b528aee8fa36c55c899d1e1 SHA512 1d77bb0a73ef2f94058ad8f991c628097c87b0ea9c7c4480d23c972ff20ea8ea2653113c8100f1611911606fe84a470650e1a2e9cc6d596d3e80960bb00900c2 WHIRLPOOL ea9f470a92ad55fbdc561d0df1ba51414c716fac158c8db28cccd18d2f106339ee8dc9eba03067f2473289f485dd1118ffedee6ea5b0fbcd0517f6ef5e68abb8
DIST fcitx-libpinyin-0.5.1_dict.tar.xz 15147796 SHA256 9464ff6bcff8ff5f89059845a26ece5fe2659b66f65fd0c4a092ee818752adc7 SHA512 85d26e5c036f5fb82005c677d8924e68236f52fab2ddf0e19472e84ca4ae66d9e8e7ec7a84cc7b7cb1da796df2e51f267336640b7957b5caf91ea13e273da411 WHIRLPOOL 676d9f71e2daf76a2b7677f381b32adb28cf3c4034ba949008b95b0fd9df9cd55ec5dfd86a3ae289e86b7e0758d72586e5d6e93267309e49ed1b2627dadb4ec7
DIST fcitx-libpinyin-0.5.2_dict.tar.xz 15149780 SHA256 26e916d39db952901c95d97d8a6bd22f0a2dd004549553f58562dec04823f66f SHA512 9ff0d55d78f6ef7967df685c494351bc61ee3f6b47924cf265c781bb7ec2d109ddc92f310b65315f4ccbca8e65eb21fa410fb0b255eec52bb3247dc7e5e04368 WHIRLPOOL d9577baa908a7a14d6d70f9fc213f8e85af671aacbd8b9cdd5fabc77b965c03be8fb5acca93df25657739e5667e3ad211782d9a203d05e45eaf913d313982d3d
+DIST fcitx-libpinyin-0.5.3_dict.tar.xz 15149856 SHA256 fccd408b9fad8becebf7f736e3309e775d045d6383742892385b69be91f89b4c SHA512 d132e0c007bd62286cfa89f6605a5315b6f5ae94a75bdd389fff1061e1547ad64c615fb0b75189d8cf35fa289a53e5d485911e06e368b2bf3af7b5a996fcd08a WHIRLPOOL 0bd75c39e148056bce90ddaff9e949b9d43093f56ec80ca0b972e40a005da8f39e481726af9d4fef993149c50287af2069fc27ae9bc3493fd7a4523f2569f6ff
diff --git a/app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.3.ebuild b/app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.3.ebuild
new file mode 100644
index 000000000000..8e48769ebe31
--- /dev/null
+++ b/app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-libpinyin"
+fi
+
+DESCRIPTION="Chinese LibPinyin input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-libpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI="https://download.fcitx-im.org/data/model.text.20161206.tar.gz -> fcitx-data-model.text.20161206.tar.gz"
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}_dict.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dictionary-manager"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libpinyin-2.1.0:=
+ dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libintl
+ dictionary-manager? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtdbus-5.7:5
+ >=dev-qt/qtgui-5.7:5
+ >=dev-qt/qtnetwork-5.7:5
+ >=dev-qt/qtwebengine-5.7:5[widgets]
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+src_prepare() {
+ if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ ln -s "${DISTDIR}/fcitx-data-model.text.20161206.tar.gz" data/model.text.20161206.tar.gz || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex dictionary-manager)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}