summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-12-16 16:55:56 -0500
committerMike Pagano <mpagano@gentoo.org>2024-12-16 16:55:56 -0500
commita7f7d0c29c9df44d4d4f1063624b1b2328c9759d (patch)
treea5c269e521999638f2f3101ec10099b67da393b1 /app-forensics
parentmedia-video/aegisub: Stabilize 3.3.3-r1 amd64, #946539 (diff)
downloadgentoo-a7f7d0c29c9df44d4d4f1063624b1b2328c9759d.tar.gz
gentoo-a7f7d0c29c9df44d4d4f1063624b1b2328c9759d.tar.bz2
gentoo-a7f7d0c29c9df44d4d4f1063624b1b2328c9759d.zip
app-forensics/lynis: add 3.1.3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/lynis/Manifest1
-rw-r--r--app-forensics/lynis/lynis-3.1.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-forensics/lynis/Manifest b/app-forensics/lynis/Manifest
index 61ee4ee65c17..3e8f7a9c3af5 100644
--- a/app-forensics/lynis/Manifest
+++ b/app-forensics/lynis/Manifest
@@ -1 +1,2 @@
DIST lynis-3.1.2.tar.gz 355241 BLAKE2B fb224f626d1e42eaaae108a986e4b93fba36b1e6a8ea23208568e3be3dac782f60a9a996ebcc512eaea0234a95e16464a931895b28e3bf8c718ccc8c40126c68 SHA512 e471549898407da3eee58fc404be1e8a166d41e1a527c8d4942882bff60e91554c3a759e08bced7a7c177ccc7a9d7a0b7cad340f3edc3b0e2a39a17302b018ae
+DIST lynis-3.1.3.tar.gz 358461 BLAKE2B 9d955ffd066f8203c9617242a2256a1561b9f99b874486a7d45666871406caf4b3ac3d5f22740171822f6dcbf2ca956d573362dbbd76936fc029df6b376bd1ec SHA512 fb4ad230c3b9d7d47d878da6abda9516d24a02b93235e42044aee2acc0890926028ce0eb947fe47e1705aed4d71080ed08e872c8b6b8592c7128eb80a8f0f002
diff --git a/app-forensics/lynis/lynis-3.1.3.ebuild b/app-forensics/lynis/lynis-3.1.3.ebuild
new file mode 100644
index 000000000000..f294c7a6665f
--- /dev/null
+++ b/app-forensics/lynis/lynis-3.1.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit bash-completion-r1 systemd
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://github.com/CISOfy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cron systemd"
+
+RDEPEND="
+ app-shells/bash
+ cron? ( !systemd? ( virtual/cron ) )"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+ sed -i -e 's/\/path\/to\///' "${S}/extras/systemd/${PN}.service" || die "Sed Failed!"
+ systemd_dounit "${S}/extras/systemd/${PN}.service" || die "Sed Failed!"
+ systemd_dounit "${S}/extras/systemd/${PN}.timer"
+
+ if ! use cron; then
+ ebegin "removing cron files from installation image"
+ rm -rfv "${ED}/etc/cron.daily" || die
+ eend "$?"
+ fi
+}
+
+pkg_postinst() {
+ if use cron; then
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ echo
+ ewarn "Both 'cron' and 'systemd' flags are enabled."
+ ewarn "So both ${PN}.target and cron files were installed."
+ ewarn "Please don't use 2 implementations at the same time."
+ ewarn "Cronjobs are usually enabled by default via /etc/cron.* jobs"
+ ewarn "If you want to use systemd ${PN}.target timers"
+ ewarn "disable 'cron' flag and reinstall ${PN}"
+ echo
+ else
+ einfo "A cron script has been installed to ${ROOT}/etc/cron.daily/lynis."
+ fi
+ fi
+}