summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-05-07 17:02:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-05-08 20:39:57 +0200
commit3bd854929d0bdb1b0f0480dec8b3b65a2efa5b91 (patch)
tree926bf690d1c7eab9f97082092440fa1bf9ed9ade /app-forensics
parentsys-apps/systemd-utils: disable py3.9 (diff)
downloadgentoo-3bd854929d0bdb1b0f0480dec8b3b65a2efa5b91.tar.gz
gentoo-3bd854929d0bdb1b0f0480dec8b3b65a2efa5b91.tar.bz2
gentoo-3bd854929d0bdb1b0f0480dec8b3b65a2efa5b91.zip
app-forensics/galleta: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/galleta/galleta-20040505_p1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-forensics/galleta/galleta-20040505_p1-r1.ebuild b/app-forensics/galleta/galleta-20040505_p1-r1.ebuild
new file mode 100644
index 000000000000..bea1416ab5a9
--- /dev/null
+++ b/app-forensics/galleta/galleta-20040505_p1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV/_p/_}"
+
+DESCRIPTION="IE Cookie Parser"
+HOMEPAGE="https://sourceforge.net/projects/odessa/"
+SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}/src"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
+}