summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-06 14:10:09 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-06 14:10:09 +0100
commit82c3d61152a5527a0f68869918c92ee2d0e46b51 (patch)
tree3c08c9a60a67f186572db8427ff1371206e86785 /app-forensics/volatility/volatility-2.6.ebuild
parentnet-fs/cifs-utils: Removed old. (diff)
downloadgentoo-82c3d61152a5527a0f68869918c92ee2d0e46b51.tar.gz
gentoo-82c3d61152a5527a0f68869918c92ee2d0e46b51.tar.bz2
gentoo-82c3d61152a5527a0f68869918c92ee2d0e46b51.zip
app-forensics/volatility: version bump, allow building against pycryptodome
Bug: https://bugs.gentoo.org/show_bug.cgi?id=599056 Bug: https://bugs.gentoo.org/show_bug.cgi?id=611582 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-forensics/volatility/volatility-2.6.ebuild')
-rw-r--r--app-forensics/volatility/volatility-2.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-forensics/volatility/volatility-2.6.ebuild b/app-forensics/volatility/volatility-2.6.ebuild
new file mode 100644
index 000000000000..c2c54c4fce8d
--- /dev/null
+++ b/app-forensics/volatility/volatility-2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="Framework for analyzing volatile memory"
+HOMEPAGE="http://www.volatilityfoundation.org/"
+SRC_URI="http://downloads.volatilityfoundation.org/releases/${PV}/${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-master
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-libs/distorm64-3[${PYTHON_USEDEP}]
+ dev-libs/libpcre
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ distutils-r1_src_install
+ mkdir "${D}/usr/share/${PN}"
+ mv "${D}/usr/contrib/plugins" "${D}/usr/share/${PN}/"
+ rmdir "${D}/usr/contrib"
+ mv "${D}/usr/tools" "${D}/usr/share/${PN}/"
+ dosym /usr/bin/vol.py /usr/bin/volatility
+}