summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-08-04 15:30:16 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-04 15:30:28 +0100
commitcec7e7ddbc8a4cb4a74a2fda1edb0cede52014a0 (patch)
tree9ed7449ac460ba57dc0da5c1602e56f08b63d35b /app-emulation
parentgames-server/bedrock-server: add 1.21.3.01, drop 1.21.2.02 (diff)
downloadgentoo-cec7e7ddbc8a4cb4a74a2fda1edb0cede52014a0.tar.gz
gentoo-cec7e7ddbc8a4cb4a74a2fda1edb0cede52014a0.tar.bz2
gentoo-cec7e7ddbc8a4cb4a74a2fda1edb0cede52014a0.zip
app-emulation/open-vm-tools: Fix cross-compiling 12.4.5 with libdnet + xmlsec
The patch has been submitted upstream. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools/files/12.4.5-xmlsec1-pc.patch57
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-12.4.5.ebuild5
2 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/open-vm-tools/files/12.4.5-xmlsec1-pc.patch b/app-emulation/open-vm-tools/files/12.4.5-xmlsec1-pc.patch
new file mode 100644
index 000000000000..9dfaad5e200c
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/12.4.5-xmlsec1-pc.patch
@@ -0,0 +1,57 @@
+https://github.com/vmware/open-vm-tools/pull/732
+
+From 9403500c9aac5be8c38b528e9cc0c711ba2f0151 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sun, 4 Aug 2024 14:53:16 +0100
+Subject: [PATCH 1/2] Also try using pkg-config to detect xmlsec
+
+The xmlsec1-config script does not help when cross-compiling. pkg-config is
+subsequently used for a version detection anyway.
+---
+ open-vm-tools/configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/open-vm-tools/configure.ac b/open-vm-tools/configure.ac
+index 26b2e950..d46a51e2 100644
+--- a/open-vm-tools/configure.ac
++++ b/open-vm-tools/configure.ac
+@@ -879,7 +879,7 @@ if test "$enable_vgauth" = "yes" ; then
+ AC_VMW_DEFAULT_FLAGS([XMLSEC1])
+ AC_VMW_CHECK_LIB([xmlsec1],
+ [XMLSEC1],
+- [],
++ [xmlsec1],
+ [xmlsec1-config],
+ [],
+ [xmlsec/xmlsec.h],
+--
+2.45.2
+
+
+From b9f0bb3205039d2fa4e8d1f6d2e4d622f3ef97b1 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sun, 4 Aug 2024 14:54:34 +0100
+Subject: [PATCH 2/2] Respect the $PKG_CONFIG variable when checking the xmlsec
+ version
+
+This particularly helps when cross-compiling.
+---
+ open-vm-tools/configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/open-vm-tools/configure.ac b/open-vm-tools/configure.ac
+index d46a51e2..39b9fa9c 100644
+--- a/open-vm-tools/configure.ac
++++ b/open-vm-tools/configure.ac
+@@ -884,7 +884,7 @@ if test "$enable_vgauth" = "yes" ; then
+ [],
+ [xmlsec/xmlsec.h],
+ [xmlSecCheckVersionExt],
+- [XMLSEC1_VER=`pkg-config --modversion xmlsec1`
++ [XMLSEC1_VER=`$PKG_CONFIG --modversion xmlsec1`
+ xmlsec1_major_version="`echo $XMLSEC1_VER | cut -f1 -d. | cut -f1 -d-`"
+ xmlsec1_minor_version="`echo $XMLSEC1_VER | cut -f2 -d. | cut -f1 -d-`"
+ xmlsec1_micro_version="`echo $XMLSEC1_VER | cut -f3 -d. | cut -f1 -d-`"
+--
+2.45.2
+
diff --git a/app-emulation/open-vm-tools/open-vm-tools-12.4.5.ebuild b/app-emulation/open-vm-tools/open-vm-tools-12.4.5.ebuild
index 96a3b32786df..9e89b64ee6c5 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-12.4.5.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-12.4.5.ebuild
@@ -64,6 +64,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/10.1.0-Werror.patch
"${FILESDIR}"/11.3.5-icu.patch
+ "${FILESDIR}"/12.4.5-xmlsec1-pc.patch
)
pkg_setup() {
@@ -100,6 +101,10 @@ src_configure() {
# Avoid a bug in configure.ac
use ssl || myeconfargs+=( --without-ssl )
+ # Avoid relying on dnet-config script, which breaks cross-compiling. This
+ # library has no pkg-config file.
+ export CUSTOM_DNET_LIBS="-ldnet"
+
econf "${myeconfargs[@]}"
}