summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-05 19:38:17 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-05 19:38:57 +0100
commit87b860d31dd7b90aa2796826e68371f2a7be81b6 (patch)
tree73583d972dc7fe8a2aba45c20712471c7630d647 /app-emulation
parentmedia-tv/kodi: Require >=x11-libs/libxkbcommon-0.4.1 (diff)
downloadgentoo-87b860d31dd7b90aa2796826e68371f2a7be81b6.tar.gz
gentoo-87b860d31dd7b90aa2796826e68371f2a7be81b6.tar.bz2
gentoo-87b860d31dd7b90aa2796826e68371f2a7be81b6.zip
app-emulation/wine: Test LINGUAS rather than linguas_* USE flags.
Fix package.masked wine ebuilds too, for completeness. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-2.0.ebuild4
-rw-r--r--app-emulation/wine/wine-2.1.ebuild4
-rw-r--r--app-emulation/wine/wine-2.2.ebuild4
-rw-r--r--app-emulation/wine/wine-2.3.ebuild4
-rw-r--r--app-emulation/wine/wine-9999.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/app-emulation/wine/wine-2.0.ebuild b/app-emulation/wine/wine-2.0.ebuild
index b2848daab085..73721746d2dd 100644
--- a/app-emulation/wine/wine-2.0.ebuild
+++ b/app-emulation/wine/wine-2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -421,7 +421,7 @@ multilib_src_install_all() {
# respect LINGUAS when installing man pages, #469418
for l in de fr pl; do
- use linguas_${l} || rm -r "${D}"usr/share/man/${l}*
+ has ${l} ${LINGUAS-${l}} || rm -r "${D}"usr/share/man/${l}*
done
}
diff --git a/app-emulation/wine/wine-2.1.ebuild b/app-emulation/wine/wine-2.1.ebuild
index f7450c265f27..d1c5a92109e9 100644
--- a/app-emulation/wine/wine-2.1.ebuild
+++ b/app-emulation/wine/wine-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -550,7 +550,7 @@ multilib_src_install_all() {
# respect LINGUAS when installing man pages, #469418
for l in de fr pl; do
- use linguas_${l} || rm -r "${D}"usr/share/man/${l}*
+ has ${l} ${LINGUAS-${l}} || rm -r "${D}"usr/share/man/${l}*
done
}
diff --git a/app-emulation/wine/wine-2.2.ebuild b/app-emulation/wine/wine-2.2.ebuild
index f7450c265f27..d1c5a92109e9 100644
--- a/app-emulation/wine/wine-2.2.ebuild
+++ b/app-emulation/wine/wine-2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -550,7 +550,7 @@ multilib_src_install_all() {
# respect LINGUAS when installing man pages, #469418
for l in de fr pl; do
- use linguas_${l} || rm -r "${D}"usr/share/man/${l}*
+ has ${l} ${LINGUAS-${l}} || rm -r "${D}"usr/share/man/${l}*
done
}
diff --git a/app-emulation/wine/wine-2.3.ebuild b/app-emulation/wine/wine-2.3.ebuild
index f7450c265f27..d1c5a92109e9 100644
--- a/app-emulation/wine/wine-2.3.ebuild
+++ b/app-emulation/wine/wine-2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -550,7 +550,7 @@ multilib_src_install_all() {
# respect LINGUAS when installing man pages, #469418
for l in de fr pl; do
- use linguas_${l} || rm -r "${D}"usr/share/man/${l}*
+ has ${l} ${LINGUAS-${l}} || rm -r "${D}"usr/share/man/${l}*
done
}
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index bf71ab62790f..42e616b03a93 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -549,7 +549,7 @@ multilib_src_install_all() {
# respect LINGUAS when installing man pages, #469418
for l in de fr pl; do
- use linguas_${l} || rm -r "${D}"usr/share/man/${l}*
+ has ${l} ${LINGUAS-${l}} || rm -r "${D}"usr/share/man/${l}*
done
}