summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-01-04 16:56:31 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-01-04 17:06:57 -0600
commit2d71953648a3154c991baec4bf8c15ba41cc4e60 (patch)
tree27f42b4d989be1d592e624f73a04fdcdc99ba08e /app-emulation
parentapp-emulation/runc: 1.0.0-rc92 bump (diff)
downloadgentoo-2d71953648a3154c991baec4bf8c15ba41cc4e60.tar.gz
gentoo-2d71953648a3154c991baec4bf8c15ba41cc4e60.tar.bz2
gentoo-2d71953648a3154c991baec4bf8c15ba41cc4e60.zip
app-emulation/docker-proxy: 0.8.0_p20201211 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-proxy/Manifest1
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/Manifest b/app-emulation/docker-proxy/Manifest
index cfe9ef71125d..d5ab0fd036e9 100644
--- a/app-emulation/docker-proxy/Manifest
+++ b/app-emulation/docker-proxy/Manifest
@@ -1,2 +1,3 @@
DIST docker-proxy-0.8.0_p20200617.tar.gz 3386043 BLAKE2B b32c3b6ef97f656414fdf026307f4054d4dd11cc91dc44a235eb5e5dc9f5f3da0cc4b001eaa28387b79f8f79f0124e6c01b8aab56d5c9e37d777e21cc186cb9c SHA512 fe8644611e975c051ee6e7ad4871624fb45862d9b4a2fd62ea4283e76ad9804d91d585e2165915b09356f11f9dfb31c40dd9ce6a66d63c5032c8c62354960538
DIST docker-proxy-0.8.0_p20201105.tar.gz 3386010 BLAKE2B 414c3d37cfe2f36dbb5cfafc6047ee0aa299ba2aeb9c5c51da308285b1e2cc0a32e83557628e0de4817651331fbcfd6b430a88fd5a0f97bb7483a8fb10ae0791 SHA512 3d81ba20a91517e14da7e75a24d4e2eeb04c1dcb9c1bfe1115247982dbdb55d2fd72d0130093e9597363b742a20f2647f229c870da9a1cbdefc69aef65f02250
+DIST docker-proxy-0.8.0_p20201211.tar.gz 3152873 BLAKE2B 01e33637a5e7619631b61a4063d85ab3c40818f090540f5737b5d50989b9dccaac91c522ccaaa6b0650427648ab8656946809740610e18de8a86108582518ede SHA512 f4f5b957fa23024b380444a0f77b5aefdd275503b89eb487785b34248d44a48e9de8dc53ba80c7f13b5666fa8c732a357ce7e4f0309aad7a35f94240381b24fb
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild
new file mode 100644
index 000000000000..f38858c48aee
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT=5c6a95bfb20c61571a00f913c6b91959ede84e8d
+ SRC_URI="https://github.com/docker/libnetwork/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+# needs dockerd
+RESTRICT="strip test"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}